Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161036 - tpctl rpm requires MIA package kernel-module-thinkpad
Summary: tpctl rpm requires MIA package kernel-module-thinkpad
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: tpctl
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 161922 162558 163466 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 05:07 UTC by Patrick Jordan
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-28 16:05:23 UTC


Attachments (Terms of Use)

Description Patrick Jordan 2005-06-20 05:07:25 UTC
Description of problem:
tpctl requires kernel-module-thinkpad, which is not in Core or extras, assume
it's referring to ibm_acpi module which is in Core kernel by default.

Version-Release number of selected component (if applicable):
tpctl-4.17-2.i386

How reproducible:
Obtain tpctl rpm, attempt to install it, watch as it fails because of
kernel-module-thinkpad dependency.

Steps to Reproduce:
1. wget
http://download.fedora.redhat.com/pub/fedora/linux/extras/4/i386/tpctl-4.17-2.i386.rpm
2. rpm -hiv tpctl-4.17-2.i386
  
Actual results:
error: Failed dependencies:
        kernel-module-thinkpad >= 3.2 is needed by tpctl-4.17-2.i386

Expected results:
Should have installed.

Additional info:

Comment 1 Ville Skyttä 2005-06-21 19:01:29 UTC
Nope, ibm_acpi is not the same thing as kernel-module-thinkpad.  
  
kernel-module-thinkpad exists currently in Extras CVS only, because there's no 
consensus on how to name/version "external" kernel module packages so that 
dependency solvers would do the right thing, and because the Extras build 
system is (possibly, not 100% investigated) somewhat lacking on the features 
needed to build the module packages sanely. 
 
Anyway, this is definitely a problem we should solve one way or another soon.  
Unless we can find a good solution, tpctl (and configure-thinkpad) will have 
to be pulled from the repository. 
 
In the meantime, you can build kernel-module-thinkpad for your kernel from 
CVS, see http://cvs.fedora.redhat.com/extras.shtml for instructions how to 
grab it, and do a "make i686" in the checked out kernel-module-thinkpad 
directory. 

Comment 2 Ville Skyttä 2005-06-28 14:47:19 UTC
*** Bug 161922 has been marked as a duplicate of this bug. ***

Comment 3 Ville Skyttä 2005-06-28 16:05:23 UTC
Discussion on kernel module packaging has restarted on the fedora-packaging   
mailing list, but in the meantime, I've requested pulling tpctl, apmiser and   
configure-thinkpad from the repository.  Resolving as DEFERRED until we start 
actually shipping the module packages. 
  
http://fedoraproject.org/wiki/Extras/FC3Status  
http://fedoraproject.org/wiki/Extras/FC4Status  

Comment 4 Ville Skyttä 2005-07-06 15:23:52 UTC
*** Bug 162558 has been marked as a duplicate of this bug. ***

Comment 5 Ville Skyttä 2005-07-17 17:57:04 UTC
*** Bug 163466 has been marked as a duplicate of this bug. ***

Comment 6 Ville Skyttä 2005-07-17 17:59:22 UTC
Status update: 
- Still no agreed way to package/ship kernel module packages 
- Required build system features for building kernel module packages missing 
- kernel-module-thinkpad, tpctl, and configure-thinkpad are up for grabs for a  
  new maintainer: http://fedoraproject.org/wiki/Extras/OrphanedPackages 


Note You need to log in before you can comment on or make changes to this bug.