Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161028 - lam should be built with -fPIC on x86_64
Summary: lam should be built with -fPIC on x86_64
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: lam
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 01:40 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 7.1.1-6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-19 08:33:08 UTC


Attachments (Terms of Use)

Description Need Real Name 2005-06-20 01:40:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.6 (KHTML, like Gecko) Safari/412.2

Description of problem:
Since only static libs are being built for the lam package, on those architectures like x86_64 and ppc_64
which require all code linked into shared libaries to be built with -fPIC, this package should be built with 
that flag. Currently x86_64 will not allow libmpi.a to be linked into a shared library because libmpi.a is 
built without -fPIC,

Version-Release number of selected component (if applicable):
lam-7.1.1-3

How reproducible:
Always

Steps to Reproduce:
1. Try to link libmpi.a into a shared library.


Additional info:

Comment 1 Jason Vas Dias 2005-07-12 18:34:57 UTC
This bug is now fixed with lam-7.1.1-6, released as FC3 and FC4 updates today.



Note You need to log in before you can comment on or make changes to this bug.