Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161024 - Anaconda throws exception after copying and installing all files
Summary: Anaconda throws exception after copying and installing all files
Keywords:
Status: CLOSED DUPLICATE of bug 160618
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-19 23:09 UTC by Matt Wood
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-20 19:29:20 UTC


Attachments (Terms of Use)

Description Matt Wood 2005-06-19 23:09:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Right before the Post Install process during an installation, anaconda throws and exception and halts the installation.  Below is the trace of the exception:

Traceback (most recent call last):
File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback self.currentWindow.renderCallback()
File "/usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback self.intf.icw.nextClicked()
File "/usr/lib/anaconda/gui.py", line 873, in nextClicked self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 1204, in doPostInstall stdout = devnull)
File "/usr/lib/anaconda/iutil.py", line 53, in execWithRedirect raise RuntimeError, command + " can not be run"
RuntimeError:  /usr/sbin/kudzu can not be run

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Begin Install process
2.  When anaconda finishes copying and installing files note the exception
3.  
  

Actual Results:  Exception thrown

Expected Results:  Post Install process begins

Additional info:

Gateway 400SD4 Laptop
Tried installing from DVD as well as HTTP.  Problem occurs during each.

Comment 1 Chris Lumens 2005-06-20 15:25:43 UTC
Please attach the full anacdump.txt file.

Comment 2 Chris Lumens 2005-06-20 19:29:20 UTC
Consolidating into the one bug report that's getting more detailed information.
 Instead of attaching anacdump.txt, you can just examine your anacdump.txt file
and see if it has these sorts of error messages towards the bottom:

error: db4 error(-30977) from db->cursor: DB_RUNRECOVERY: Fatal error, run
database recovery

*** This bug has been marked as a duplicate of 160618 ***


Note You need to log in before you can comment on or make changes to this bug.