Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161018 - abnormal/missing icons in gnome
Summary: abnormal/missing icons in gnome
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: control-center
Version: 4.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Control Center Maintainer
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-19 21:32 UTC by Rohit V. Kapoor
Modified: 2009-02-16 17:36 UTC (History)
4 users (show)

Fixed In Version: RHEL5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-16 17:36:59 UTC


Attachments (Terms of Use)

Description Rohit V. Kapoor 2005-06-19 21:32:32 UTC
This problem still occurs in RHEL 4.0. Pretty serious that GNOME settings are
not retained per X session, only per user and host.

+++ This bug was initially created as a clone of Bug #141874 +++

Description of problem:
In FC2, many icons on desktop, taskbar, and filesystem browser do not 
appear normally using Gnome desktop manager via a VNC server 
display.  Logged in using regular user.  Icons appear normally when 
logging into computer console.

Version-Release number of selected component (if applicable):
4.0.5.i386 (using Win32 VNC client 3.3.7)

How reproducible:
consistently

Steps to Reproduce:
1. change default $HOME/.vnc/xstartup
2. configure regular user to use Gnome as desktop manager
3. start vncserver process from shell login of regular user 
4. connect to FC2 computer using vnc client from another computer
5. observe icons as abnormal
  
Actual results:
icons do not show normally

Expected results:
icons show normally

Additional info:


---- contents of $HOME/.vnc/xstartup: ----
#!/bin/sh 

# Uncomment the following two lines for normal desktop: 
unset SESSION_MANAGER 
exec /etc/X11/xinit/xinitrc 

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup 
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources 
xsetroot -solid grey 
vncconfig -iconic & 
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" & 
twm & 
---- End of $HOME/.vnc/xstartup: ----

Comment 1 Mark McLoughlin 2005-06-20 07:44:46 UTC
Long standing control-center issue:

  http://bugzilla.gnome.org/show_bug.cgi?id=94049

From bug #141874:

---
Okay, I what's happening is:

  1) You log in as "foo" to a normal session

  2) You then run Xvnc from a terminal, with a gnome session running
      on the VNC server. The gnome session is running as "foo" too.

  3) Because gnome-settings-daemon registers as a per-user, per-host 
     daemon it doesn't get run in the VNC session - i.e. you really
     need a g-s-d for both sessions, but you're only getting one
     g-s-d.
---

Comment 2 Ray Strode [halfline] 2005-06-20 13:16:03 UTC
Hey Mark,

Didn't you commit the patch in the bug report a while ago?  I vaguely remember
you and Jonathan talking about it and Jonathan saying to just commit it.

Comment 3 Mark McLoughlin 2005-06-20 13:19:36 UTC
I think Jody was still dubious ... can't remember for sure, though

Comment 4 Jong Bae KO 2009-02-14 03:01:48 UTC
Hi 

Is it fix on RHEL5 or latest RHEL4?

Comment 5 Ray Strode [halfline] 2009-02-16 17:36:59 UTC
This is fixed in RHEL5, but not in RHEL4.


Note You need to log in before you can comment on or make changes to this bug.