Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161014 - login ( pam_unix ) authentication failure
Summary: login ( pam_unix ) authentication failure
Keywords:
Status: CLOSED DUPLICATE of bug 160929
Alias: None
Product: Fedora
Classification: Fedora
Component: pam
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-19 20:42 UTC by Nadav Kavalerchik
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-20 12:12:17 UTC


Attachments (Terms of Use)

Description Nadav Kavalerchik 2005-06-19 20:42:42 UTC
Description of problem:
after upgrading (using yum) from fc3-rawhide to fc4. i can't login.
i get login failed !

Version-Release number of selected component (if applicable):
i got pam ver 0.79-10

How reproducible:
booting the system and trying to login.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
/var/log/messages...
login(pam_unix)[2329]: authentication failure; logname= uid=0 euid=0 tty=tty2 
ruser= rhost=  user=root
Jun 19 15:23:22 harmony login[2329]: FAILED LOGIN SESSION FROM (null) FOR root, 
System error
Jun 19 15:23:22 harmony login(pam_unix)[2329]: 1 more authentication failure; 
logname= uid=0 euid=0 tty=tty2 ruser= rhost=  user=root
Jun 19 15:23:26 harmony login(pam_unix)[2370]: authentication failure; logname= 
uid=0 euid=0 tty=tty2 ruser= rhost=  user=root
Jun 19 15:23:29 harmony login[2370]: FAILED LOGIN SESSION FROM (null) FOR root, 
System error
Jun 19 15:23:29 harmony login(pam_unix)[2370]: 1 more authentication failure; 
logname= uid=0 euid=0 tty=tty2 ruser= rhost=  user=root
Jun 19 15:23:38 harmony login(pam_unix)[2410]: authentication failure; logname= 
uid=0 euid=0 tty=tty2 ruser= rhost=  user=nadav
Jun 19 15:23:41 harmony login[2410]: FAILED LOGIN SESSION FROM (null) FOR 
nadav, System error
Jun 19 15:23:41 harmony login(pam_unix)[2410]: 1 more authentication failure; 
logname= uid=0 euid=0 tty=tty2 ruser= rhost=  user=nadav
Jun 19 15:23:47 harmony login(pam_unix)[2452]: authentication failure; logname= 
uid=0 euid=0 tty=tty2 ruser= rhost=  user=nadav
Jun 19 15:23:51 harmony login[2452]: FAILED LOGIN SESSION FROM (null) FOR 
nadav, System error
Jun 19 15:23:51 harmony login(pam_unix)[2452]: 1 more authentication failure; 
logname= uid=0 euid=0 tty=tty2 ruser= rhost=  user=nadav

Comment 1 Tomas Mraz 2005-06-20 06:54:56 UTC
Which version of audit-libs package do you have? And which kernel?
Do you have SELinux on?


Comment 2 Nadav Kavalerchik 2005-06-20 07:51:16 UTC
i'm using audit-libs 0.9.8-1 and kernel 2.6.11-1.1287_FC4
and i don't use selinux.

while...
booting into INIT 1 and trying to change root's passwd i get System Error after 
the passward change in the /etc/shadow file.
and trying to login returns "login incurrect"
i added new user with passward and without password... still the same !
i changed the /etc/pam.d/login auth,pass file params to md5, shadow , 
nullok ... more , and still the same error.


Comment 3 Tomas Mraz 2005-06-20 09:03:56 UTC
Hmm this seems like duplicate of bug 160929. Could you try to upgrade to a newer
kernel?


Comment 4 Nadav Kavalerchik 2005-06-20 12:01:43 UTC
true, it a duplicate of bug 160929 !    
    
and after upgrading to kernel 1383_fc5 the problem was solved too :-)    
thanks !   

Comment 5 Tomas Mraz 2005-06-20 12:12:17 UTC

*** This bug has been marked as a duplicate of 160929 ***


Note You need to log in before you can comment on or make changes to this bug.