Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161013 - No apparent support for a Samsung SyncMaster 910v Monitor
Summary: No apparent support for a Samsung SyncMaster 910v Monitor
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display
Version: 4
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2005-06-19 20:29 UTC by alien
Modified: 2008-08-02 23:40 UTC (History)
0 users

Fixed In Version: 0.160-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-04-03 18:22:04 UTC

Attachments (Terms of Use)
updated monitors database (deleted)
2005-06-27 15:13 UTC, Bill Nottingham
no flags Details

Description alien 2005-06-19 20:29:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
AMD Athlon 64 CPU Chip,Maxtor 80GB Hard Drive, Radeon 9200 Graphics Card, Samsung SyncMaster 910v Monitor, LG DVD/CD drive, Linksys PCI Wireless Adapter, USB 2.0

Downloaded Installed the x86_64 version of the Fedora Core 4 (June 13, 2005)

-Installation program (anaconda) worked fine for the pre-install section
-Anaconda then formated/installed the code from the 4 CDs
-After FC4 was successfully loaded onto the harddrive, performed a reboot
-responded to the post-install questions (I assume tis is still anaconda)
-after all the questions, the screen resets... and the result is blank/black or a garbled screen image...
-my only choice is to power-off the PC... and reboot
-System again comes up again...the screen appears fine...but as it displays the login screen... the screen is once again all garbled (or blank/black)

the only way I can figure to fix this is to completely re-install the FC4 code... and choose different monitor types within the post-install phase... I try to choose something that comes close to what I have... but... whatever I seem to pick... the end result is a garbled screen !!

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce: Linux Fedora Core 4 Install Disk into CD drive the system
3.respond to FC4 pre-install questions
4.FC4 formats/installs code to the hard drive
5.System reboots
6.Respond to post-install questions
  a) the installer realizes that it is working with an unknown monitor type
  b) 3 or 4 montior type that come close to matching Samsung SyncMaster 910v
      -- understand for each attempt... I have to perform a complete install
7.After all the post-install questions are complete...
  -- the screen resets itself.. and everything is all garbled on the screen


Actual Results:  There is garbage on the screen.

Expected Results:  To be able to see and understand what is on the screen/monitor

Additional info:

I figure if I re-boot the system using a "Rescue CD", and then make my way to the file  /etc/X11/xorg.conf..... then update the monitor definition to the "proper" value... all should work.

I just would NOT know what to code !!

Comment 1 Bill Nottingham 2005-06-20 16:39:24 UTC
Do you have a INF file for this monitor?

Comment 2 alien 2005-06-23 12:27:57 UTC
   Yes...  here is the .INF file...

; SM910V.inf 01/30/2004 ver. 1.0
; Copyright 2004 Samsung Electronics Corporation
; This is a Setup information file for Samsung Monitor. 





DefaultDestDir = 11
SM910V.CopyFiles = 23




; Manufacturer sections
%SM910V%=SM910V.Install, Monitor\SAM0115

; Install Sections

AddReg=SM910V.AddReg, 1280, DPMS

; Addreg & DelReg sections




; AddReg sections





DISK="Samsung Monitor Installation Disk"
SM910V="SyncMaster 910V/910M/913V"

Comment 3 Bill Nottingham 2005-06-23 17:11:54 UTC
Thanks, added in CVS, will be in hwdata-0.160-1.

Comment 4 alien 2005-06-25 04:23:33 UTC
   Ummm.... please excuse my ignorance here. The fact that it has now been added
to hwdata-0.160-1 ... I guess means that the situation has now been resolved ?!?

    Again, I am sitting here with 4 CDs burnt from the June 13th ISO images for
the x86_64 Linux code. I am not quite sure what I am supposed to do right now !!

Comment 5 Bill Nottingham 2005-06-27 15:13:45 UTC
Created attachment 116016 [details]
updated monitors database

The data for the monitor will be added to the MonitorsDB as of that release of
the hwdata package.

In the meantime, I'd suggest booting in text mode, and dropping this file in
/usr/share/hwdata; you'd then at least be able to pick it if you then run
system-config-display. This could be problematic if the config is illegible,

For that, probably the best is to just pick a Generic 640x480 or 800x600
display, and *then* copy in this file and pick the correct monitor. If, once
you have the correct monitor selected, it still doesn't work, that's probably
an X bug.

Comment 6 alien 2005-08-27 14:18:02 UTC
Well I finally downloaded hwdata-0.164-1.noarch.rpm onto my test (i386) Linux
system (not the system mentioned above)... and extracted the MonitorsDB file and
copied it to a floopy disk

I then, once again, went through the process of completely re-installing the FC4
x86 code onto my AMD Athlon 64 3400+ system.. the one that has the Samsung
SyncMaster 910v monitor

When the install procesf completed its code install, and requested a system
restart... I intervened with the FC4 "rescuecd"... mounted the drives... copied
the MonitorsDB file into /usr/share/hwdata.... then rebooted again... (and
removed the rescuecd.

I then let the post-install process of the FC4 (x86) package to complete. Again,
it detected an unknown monitor (screen)... i then selected from the available
list of known monitors/screens... I saw that SysncMaster 910v was noavailable...
and I selected it !

I couple of more screen-panels later... the install code reset the screen... it
was all BLACK ! Again I can not do anything. !@#$%

Again, using the rescuecd, I updated the /etc/inittab, and changed the init-mode
 from '5' (graphical) to '3' (text)

Now when I re-boot the system, it comes up in test-mode... and I am able to
logon with no problems. (wo-pee !)

Once logged onto my general (non-root) userid, I enter "startx".... again get
into a BLACK screen !

Is there some text-based configurator I can possible use to dig my way out of
this problem? 

Any help would be certainly appreciated. Thanks.


Comment 7 Adam Jackson 2006-03-22 20:01:48 UTC
If this is still a problem with FC5, please attach the X log from the broken
startup (ie, wait for X to start and the screen to go black, ssh in and copy the
log file off).

Comment 8 Adam Jackson 2007-04-03 18:22:04 UTC
NEEDINFO timeout, resolving as INSUFFICIENT_DATA.  If you are still experiencing
this bug in FC6 or FC7, please reopen.  Thanks for the report!

Note You need to log in before you can comment on or make changes to this bug.