Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161002 - binary does not start up
Summary: binary does not start up
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-blog
Version: 4
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-19 17:18 UTC by Thilo Pfennig
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-20 01:35:15 UTC


Attachments (Terms of Use)

Description Thilo Pfennig 2005-06-19 17:18:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
gnome-blog crashes on startup with a python error: "SystemError: NULL result without error in PyObject_C"

Version-Release number of selected component (if applicable):
gnome-blog-0.8-9.fc4

How reproducible:
Always

Steps to Reproduce:
1. execute gnome-blog-poster on terminal

  

Actual Results:  output is:

/usr/lib/python2.4/site-packages/gtk-2.0/gnome/vfs.py:4: DeprecationWarning: Module gnome.vfs is deprecated; please import gnomevfs instead
  DeprecationWarning)
Using gconf_prefix /apps/gnome-blog
/usr/lib/python2.4/site-packages/gnomeblog/rich_entry.py:21: GtkDeprecationWarning: gtk.TRUE is deprecated, use True instead
  self.set_editable(gtk.TRUE)
Traceback (most recent call last):
  File "/usr/bin/gnome-blog-poster", line 51, in ?
    app = BloggerApp()
  File "/usr/bin/gnome-blog-poster", line 37, in __init__
    on_entry_posted=self._onEntryPosted)
  File "/usr/lib/python2.4/site-packages/gnomeblog/blog_poster.py", line 41, in __init__
    gtkspell.Spell(self.blogEntry)
SystemError: NULL result without error in PyObject_C

Expected Results:  just run.

Additional info:

Comment 1 Brian Pepple 2005-06-19 18:00:48 UTC
Was this an upgrade from FC3 or a new install with yum on FC4?

Comment 2 Thilo Pfennig 2005-06-19 23:26:51 UTC
new install. old /home.

Comment 3 Brian Pepple 2005-06-20 01:35:15 UTC
Pretty odd.  I hadn't installed Gnome-blog yet, since loading FC4 last week, so
I tried it this afternoon using yum, and it works fine.  Hmmm.

Looks like this is being worked on upstream
(http://bugzilla.gnome.org/show_bug.cgi?id=172578), so obviously, your not the
only one experiencing this.

Comment 4 han pingtian 2005-08-10 08:15:14 UTC
I have the same problems. Create a new account, login with the new account,the
gnome-blog works very well.


Note You need to log in before you can comment on or make changes to this bug.