Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161 - Java Frame.setTitle("foo") does not work in Netscape 4.07
Summary: Java Frame.setTitle("foo") does not work in Netscape 4.07
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netscape
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-23 03:59 UTC by urs.rohrer
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-17 20:25:14 UTC


Attachments (Terms of Use)

Description urs.rohrer 1998-11-23 03:59:18 UTC
I am using the Intel version:
The Linux version of Netscape 4.07 (included in Redhat 5.2)
has a bug in its Java (1.1.5) applet part. The version of
Netscape 4.05 (included in Redhat 5.1) did not show this
bug in its Java (1.1.2) applet part.

Description:
If a frame in a java applet is displayed, then the title
of the frame is not the one asked for by the java code
setTitle("foo") or super("foo"). Instead the titles are
AWTapp, AWTapp <2>, AWTapp <3> etc for the different frames.

Demonstration:
Run my applet at http://pc102.psi.ch/accstapp.htm

Additional remarks:
This bug may be related to javasoft's bug report 4091304
(see http://developer.javasoft.com)
With the Windows 95/98/NT versions of Netscape browsers
this bug does not show up.
Downloading the newest 4.5 Linux Intel version an running it
shows the same bug !!

Comment 1 Preston Brown 1998-11-23 12:28:59 UTC
We have verified this as a bug, and hopefully it will be fixed in the
next release of Netscape.

Comment 2 Bill Nottingham 1999-06-17 20:25:59 UTC
can't reproduce with 6.0, ns 4.6


Note You need to log in before you can comment on or make changes to this bug.