Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160996 - Track Pop-Down Menu doesn't appear
Summary: Track Pop-Down Menu doesn't appear
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: audacity
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Gérard Milmeister
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-19 15:56 UTC by Mark Knoop
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-22 19:45:46 UTC


Attachments (Terms of Use)

Description Mark Knoop 2005-06-19 15:56:58 UTC
Description of problem: The Track Pop-Down Menu either does not appear or
appears only very occasionally when clicking in the track title.

Version-Release number of selected component (if applicable): audacity-1.2.3-5

How reproducible: 99%. I can occasionally get the menu to appear when clicking
on the track title whilst another application's window has focus (i.e. audacity
is behind another window). 

Steps to Reproduce:
1. Start audacity
2. Create a new track of any type, or import audio to create a track
3. Click the track name
  
Actual results: The track name button receives the click (i.e. changes to
"pressed") but the menu does not appear.

Expected results: The Track Pop-Down Menu should appear.

Additional info: This may perhaps be a wxGTK2 bug.

Comment 1 Michael Schwendt 2005-06-19 17:32:41 UTC
Cannot reproduce. Double-click works for me.

Comment 2 Mark Knoop 2005-06-20 07:53:29 UTC
You are correct - doubleclick does work. This is, therefore, a documentation
bug: the help file definitely says "The Track Pop-Down Menu appears when you
click in a track's title." 

Single-click was also, I am sure, the behavior in earlier versions.

Comment 3 Gérard Milmeister 2005-06-22 19:45:46 UTC
I don't think we should correct bugs in the documentation ourselves, so please
file a bug upstream.

Comment 4 Steven Garrity 2005-07-17 16:11:52 UTC
I don't the the menu is supposed to be a double-click menu. All previous
versions of Audacity, and when I compile 1.2.3 from source, have a single-click
for this menu.

How does what is packaged in Extras differ from upstream? Perhaps it is related
to the "--with gtk1" compile-time option? When I build from source (upstream), I
get gtk1-looking widgets (and single click track menus). When I run the Extras
version, I get gtk2-looking widgets (and double-click track menus).


Note You need to log in before you can comment on or make changes to this bug.