Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160988 (FC4_GPGKEY) - yum default config on FC4 fails because packages signed with RH key
Summary: yum default config on FC4 fails because packages signed with RH key
Keywords:
Status: CLOSED NEXTRELEASE
Alias: FC4_GPGKEY
Product: Fedora
Classification: Fedora
Component: distribution
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
: 169407 174750 174751 174752 174754 174755 174757 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-19 13:47 UTC by Chris Ricker
Modified: 2014-01-21 22:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-20 16:36:21 UTC


Attachments (Terms of Use)

Description Chris Ricker 2005-06-19 13:47:42 UTC
I did a small basic FC4 install using anaconda, then started adding the stuff I
needed using yum. In a few cases, the installs would fail because of errors like:

Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID db42a60e
public key not available for sgml-common-0.6.3-17.noarch.rpm
Retrieving GPG key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

The GPG key at file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora (0x4F2A6FD2) 
is already installed but is not the correct key for this package.
Check that this is the correct key for the "Fedora Core 4 - i386 - Base" repository.


Doing 

# rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY

fixes the problem for the couple of packages I saw this on

The issue is that packages in Fedora Core are signed with (at least) two
different keys. Most are signed with /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora but
some are instead signed with /etc/pki/rpm-gpg/RPM-GPG-KEY

To fix,

gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY

should be added to either /etc/yum.conf or /etc/yum.repos.d/fedora.repo to go
along with the 

gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

that's already there

Comment 1 Seth Vidal 2005-06-19 14:37:21 UTC
Refiling under general distro b/c the distro shouldn't be signed with two keys.


Comment 2 Bill Nottingham 2005-06-20 16:36:21 UTC
Closing as NEXTRELEASE; we'll take better care of this with FC5, but there's not
much that can be done for FC4 at this point.

Comment 3 Jeremy Katz 2005-09-27 22:09:45 UTC
*** Bug 169407 has been marked as a duplicate of this bug. ***

Comment 4 bastiaan 2005-10-12 20:39:45 UTC
In response to comment #2: a lot can be done for FC4 at this point. All that's
needed is an updated fedora-release RPM with a fedora.repo containing the extra
gpgkey= file. This will save a lot of people the hassle of finding out the 'rpm
--import /etc/pki/rpm-gpg/RPM-GPG-KEY' workaround by them selves. And a lot of
duplicate bugreports as well....



Comment 5 Warren Togami 2005-12-01 22:47:20 UTC
*** Bug 174750 has been marked as a duplicate of this bug. ***

Comment 6 Warren Togami 2005-12-01 22:47:25 UTC
*** Bug 174752 has been marked as a duplicate of this bug. ***

Comment 7 Warren Togami 2005-12-01 23:28:18 UTC
*** Bug 174757 has been marked as a duplicate of this bug. ***

Comment 8 Warren Togami 2005-12-01 23:28:34 UTC
*** Bug 174751 has been marked as a duplicate of this bug. ***

Comment 9 Warren Togami 2005-12-01 23:28:50 UTC
*** Bug 174754 has been marked as a duplicate of this bug. ***

Comment 10 Warren Togami 2005-12-01 23:29:03 UTC
*** Bug 174755 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.