Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160986 - Anaconda cannot handle "LABEL=foo" style fstab entries
Summary: Anaconda cannot handle "LABEL=foo" style fstab entries
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-19 13:44 UTC by david.hagood
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-21 21:05:41 UTC


Attachments (Terms of Use)
The offending fstab entry (deleted)
2005-06-19 13:44 UTC, david.hagood
no flags Details

Description david.hagood 2005-06-19 13:44:11 UTC
Description of problem:
Anaconda cannot parse fstabs that contain "LABEL=foo" style mounts

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Create a system with "LABEL=foo" style mounts for root file system.
2. Try to do an upgrade with FC4 anaconda

  
Actual results:
Anacoda barfs with "One of your filesystem is in a consistant state" error, and
offers no choice but to reboot.

Expected results:
Anaconda should figure out the mount, or at least allow me to hand-mount the
filesystem on another console and try again.

Additional info:
Anaconda has had this problem since RH8.

Comment 1 david.hagood 2005-06-19 13:44:11 UTC
Created attachment 115662 [details]
The offending fstab entry

Comment 2 Chris Lumens 2005-06-20 20:17:23 UTC
This appears to be working for me on an FC3 -> FC4 upgrade.  Can you switch over
to tty3 (ctrl-alt-f3) and see if there are any obvious error messages? 
Additionally, can you attach the /tmp/anaconda.log file to this report?

Comment 3 david.hagood 2005-06-20 23:32:08 UTC
OK, the info on VC3 is:
Moving (1) to step welcome
moving (1) to step findrootparts
isys.py:mount()- going to mount /tmp/hda1 on /mnt/sysimage
isys.py:mount()- going to mount /tmp/hda6 on /mnt/sysimage
isys.py:mount()- going to mount /tmp/sda1 on /mnt/sysimage
isys.py:mount()- going to mount /tmp/sda2 on /mnt/sysimage
moving (1) to step findinstall
moving (1) to step partitionobjinit
error munging swap label: [Errno 22] Invalid argument
error reading jfs label on /tmp/disk: [Errno 2] Invalid argument
moving (1) to step upgrademount
going to mount hda6 on /mnt/sysimage as ext3
isys.py:mount()- going to mount /tmp/hda6 on /mnt/sysimage
error mungin swap label: [Errno 22] Invalid argument
error reading jfs label on /tmp/disk: [Errno 22] Invalid argument
trying to mount sda2 on /mnt/work
...

And from there out there are no unusual looking messages.



Comment 4 Chris Lumens 2005-06-21 15:17:43 UTC
Workaround - change your fstab entries to specify a filesystem instead of saying
"auto" for those labeled entries.

Comment 5 david.hagood 2005-06-21 22:10:43 UTC
OK, so, that's it? Just a work-around, not an effort to actually fix the problem?

Or does this mean "closed, will be fixed in Rawhide"?

The whole idea of having things like label mounts and fstype=auto is to allow
the system to better handle changes without needed to tweak a bunch of files.

If Anaconda cannot deal with the same setups that mount does, then Anaconda is
BROKEN.

Comment 6 Chris Lumens 2005-06-22 13:43:05 UTC
No, the workaround was for your immediate benefit so you can do whatever you
need to do while we work on another anaconda release.  The "closed - rawhide"
means I have committed a fix for it.  From the CVS commit mailing list:

 2005-06-21  Chris Lumens  <clumens@redhat.com>

+       * fsset.py (AutoFileSystem):  Add mount and umount methods so entries
+       in /etc/fstab marked as "auto" can still be mounted on upgrade
+       (#160986).



Note You need to log in before you can comment on or make changes to this bug.