Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160971 - plone alpha 2.1 put into extras instead of extras/testing
Summary: plone alpha 2.1 put into extras instead of extras/testing
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: plone
Version: 3
Hardware: noarch
OS: Linux
medium
high
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL: www.kube.homelinux.net
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-19 11:27 UTC by Keith Kube
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-01 12:39:04 UTC


Attachments (Terms of Use)

Description Keith Kube 2005-06-19 11:27:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I believe that this is an alpha (testing) package.  Hence I beleive that this should be in http://download.fedora.redhat.com/pub/fedora/linux/extras/testing/3/i386/ instead of http://download.fedora.redhat.com/pub/fedora/linux/extras/3/i386/

because I have been running automated YUM updates, I've inadvertantly installed this alpha package of plone over the top of the stable 2.0.5.  

My plone sites have been down since 2.1 alpha was installed.

not all plone sites in the zope instance are crashing.  One plone site works, providing i am not using the ZMI to access it.  However, I think that this is an aside issue.

Version-Release number of selected component (if applicable):
plone-2.1-0.1.alpha2.fc3.noarch.rpm

How reproducible:
Sometimes

Steps to Reproduce:
1. install plone via yum - fc3 extras package
2. have yum install all updates
3. attempt to use plone website - www.kube.homelinux.net

Actual Results:  Site Error: AttributeError: typesToList (Also, an error occurred while attempting to render the standard error message.)


Expected Results:  In my opinion, plone-2.1-0.1.alpha2.fc3.noarch.rpm should be in the testing directory for FC3, not in the primary extras directory

Additional info:

Comment 1 Keith Kube 2005-06-19 11:51:50 UTC
Correction - all zope sites are crashing, the one site I thought wasn't was on
another machine.

Comment 2 Aurelien Bompard 2005-06-19 11:59:45 UTC
The problem is : Plone 2.0.x does not work with Zope 2.8, and Zope 2.8 has been
published into FC-3 (it should have waited for FC4, my mistake here). Only Plone
2.1 works with Zope 2.8
In addition, Plone 2.4 does not work with python 2.4 (shipped in FC4), so I have
to update it to 2.1 anyway.

Comment 3 Keith Kube 2005-06-19 12:20:14 UTC
(In reply to comment #2)
> The problem is : Plone 2.0.x does not work with Zope 2.8, and Zope 2.8 has been
> published into FC-3 (it should have waited for FC4, my mistake here). Only Plone
> 2.1 works with Zope 2.8
> In addition, Plone 2.4 does not work with python 2.4 (shipped in FC4), so I have
> to update it to 2.1 anyway.

Thanks for getting back to this so quick.
This still leaves me with all my plone sites being down (see
www.kube.homelinux.net for a detailed traceback).  Any suggestions on how to
move forward.  Do I try to rollback the plone instance, or try to solve the
problems?  

Comment 4 Aurelien Bompard 2005-06-19 15:47:17 UTC
I'd suggest to rollback both plone and zope for the moment. Sorry about that.


Note You need to log in before you can comment on or make changes to this bug.