Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160966 - failure in compilation missing lib2gc
Summary: failure in compilation missing lib2gc
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: compat-gcc-32
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
: 160963 160964 160965 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-19 10:14 UTC by André Fettouhi
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-20 07:31:54 UTC


Attachments (Terms of Use)

Description Jakub Jelinek 2005-06-19 22:58:31 UTC
*** Bug 160963 has been marked as a duplicate of this bug. ***

Comment 1 Jakub Jelinek 2005-06-19 22:58:48 UTC
*** Bug 160964 has been marked as a duplicate of this bug. ***

Comment 2 Jakub Jelinek 2005-06-19 22:59:26 UTC
*** Bug 160965 has been marked as a duplicate of this bug. ***

Comment 3 André Fettouhi 2005-06-20 06:19:14 UTC
I have fix for it, it seems like that symlink from libg2c.so.0 to libg2c.so is
missing in /usr/lib (thanks to Axel Thimm for pointing that out). If that
symlink is added then libg2c can be found, i.e. -lg2c works. This should added
in an pudate of the package.

Kind Regards

André Fettouhi

Comment 4 Jakub Jelinek 2005-06-20 07:31:54 UTC
No, it shouldn't.
libg2c.so symlink is intentionally in
/usr/lib/gcc-lib/*-redhat-linux/3.2.3/libg2c.so
as it is a compiler version specific library.
You should be mixing g77 3.2.3 objects with gcc 3.2.3 or g++ 3.2.3 compiled
objects and link with the compatibility compiler as well, then it will work
just fine.


Note You need to log in before you can comment on or make changes to this bug.