Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160962 - SDL should use ALSA output by default
Summary: SDL should use ALSA output by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: SDL
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-19 09:58 UTC by Jens Knutson
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-27 13:20:57 UTC


Attachments (Terms of Use)

Description Jens Knutson 2005-06-19 09:58:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
When playing some of the SDL games from Fedora Extras (SuperTux, Starfighter, etc), I was getting corrupted/clipped music and sound effects.  I noticed that when I launched these games that the vile esound daemon was getting launched, too.

A bit of googling, I found that exporting "SDL_AUDIODRIVER=alsa" fixed this completely.  I'm not sure how this should be accomplished, but given that Fedora is pushing for pure ALSA usage, it seems like ALSA should be the default for SDL.

Version-Release number of selected component (if applicable):
SDL-1.2.8-3.2

How reproducible:
Always

Steps to Reproduce:
1. Install SuperTux from Fedora Extras
2. Get corrupted/clipped sound
3. Quit SuperTux
4. Open a shell and do "export SDL_AUDIODRIVER=alsa"
5. from that shell, launch SuperTux
6. enjoy the sounds and music as they were intended
  

Additional info:

Comment 1 Richard Henderson 2005-08-24 04:46:53 UTC
Agnostic to whether a daemon should be preferred over direct sound access
(see SDL-1.2.3-prefersounddaemons.patch included in the rpm), note that OSS
is searched before ALSA.  Which ought to be considered a bug under FC[45].

The fix being as simple as modifying the table in src/audio/SDL_audio.c.

Comment 2 Marius Andreiana 2005-11-03 09:18:10 UTC
Could this be fixed before FC5 beta1 comes out this month?

Comment 3 Thomas Woerner 2006-01-27 13:20:57 UTC
Fixed in rawhide in rpm SDL-1.2.9-4 and in FC-4 updates in rpm SDL-1.2.8-4.


Note You need to log in before you can comment on or make changes to this bug.