Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160951 - system-config-bind non-ascii characters is broken on menus
Summary: system-config-bind non-ascii characters is broken on menus
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-bind
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-19 08:16 UTC by sangu
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 4.0.0-21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-05 00:04:22 UTC


Attachments (Terms of Use)
LANG=ko_KR.UTF-8, system-config-bind on menu (deleted)
2005-06-19 08:16 UTC, sangu
no flags Details

Description sangu 2005-06-19 08:16:18 UTC
Description of problem:
system-config-bind non-ascii characters is broken on menus 

cat /usr/share/applications/system-config-bind.desktop
ja, ko, zn_CN, zh_TW characters are broken in LANG=ko_KR.UTF-8

Version-Release number of selected component (if applicable):
system-config-bind-4.0.0-16_FC4

How reproducible:
always

Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 sangu 2005-06-19 08:16:19 UTC
Created attachment 115661 [details]
LANG=ko_KR.UTF-8, system-config-bind on menu

Comment 2 Jason Vas Dias 2005-07-18 14:43:56 UTC
The problem is with the localized strings in system-config-bind.desktop 
(installed as /usr/share/applications/system-config-bind.desktop) or with
the asian fonts packages installed on your system.
I do not read Korean, Japanese or Chinese - please can you correct the 
desktop file and attach it to this bug .


Comment 3 sangu 2005-07-18 16:13:04 UTC
$rpm -q system-config-bind
system-config-bind-4.0.0-18_FC5
$file /usr/share/applications/system-config-bind.desktop
/usr/share/applications/system-config-bind.desktop: UTF-8 Unicode English text,
with LF, NEL line terminators
$ lv /usr/share/applications/system-config-bind.desktop

Jason Vas Dias : Except serveral locale string, most of strings seem to be
broken. and I do not read and type Japanese and Chinese, too. Sorry!

----

Name[ko]=ëë©ì¸ ë¤ì ìì¤í
Comment[ko]=bind ìë¹ì¤(DNS) ì¤ì 

Comment 4 Akira TAGOH 2005-07-27 02:31:46 UTC
Why were the desktop file excluded from POTFILES? AFAICS it should be generated
against the translated strings from every po files and intltool could treats it
properly. but it's not right now. that's why the desktop file is broken. please
revive that and don't update the desktop file itself. it sometimes causes the
out of sync and not easier way for the translators.

Comment 5 Jason Vas Dias 2005-07-27 13:47:58 UTC
This is now fixed with system-config-bind-4.0.0-21 in elvis CVS - the desktop
file strings have now been added to the .po files and the desktop file is now
regenerated with intltool during the build.



Note You need to log in before you can comment on or make changes to this bug.