Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160949 - LogWatch Disk Space display truncated (with long LV names)
Summary: LogWatch Disk Space display truncated (with long LV names)
Keywords:
Status: CLOSED DUPLICATE of bug 152419
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: logwatch
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jiri Ryska
QA Contact:
URL:
Whiteboard:
: 164256 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-19 07:14 UTC by Patrick C. F. Ernzer
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-20 13:02:16 UTC


Attachments (Terms of Use)

Description Patrick C. F. Ernzer 2005-06-19 07:14:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
I try to have my logical volumes named rater verbosely, this leads to longer names than ususal. Just in case the length plays in this)

When logwatch-5.2.2-1 sends me e-mail, the Disk Space display is truncated.

This happened for the first time on 2005-04-25. Previously the display was not nice to look at but the info was there.

Version-Release number of selected component (if applicable):
logwatch-5.2.2-1

How reproducible:
Always

Steps to Reproduce:
1. have a machine that is on most of the time (it's a test system and sometimes it gets powered down when I need it's power, network and KVM cords)
2. appply all errate more or less a they come out
3. have logwatch installed
  

Actual Results:  ------------------ Disk Space --------------------

/dev/mapper/VG00-LV_root
/dev/hde1              99M   12M   82M  13% /boot
/dev/mapper/VG00-LV_home
/dev/mapper/VG00-LV_rhndbbackup
/dev/mapper/VG00-LV_rhnsat
/dev/mapper/VG00-LV_var
/dev/mapper/VG00-LV_var_satellite


 ###################### LogWatch End ######################### 

(I've had this display all through RHEL4)

Expected Results:  Display as it was in RHEL 3:

------------------ Disk Space --------------------

Filesystem            Size  Used Avail Use% Mounted on
/dev/VG00/LogVol_root
                      3.4G  2.4G  832M  75% /
/dev/hde1             145M   15M  123M  11% /boot
/dev/VG00/LogVol_home
                      104G   49G   51G  49% /home
none                  376M     0  376M   0% /dev/shm
/dev/VG00/LogVol_rhndbbackup
                       35G  528M   33G   2% /rhndbbackup
/dev/VG00/LogVol_rhnsat
                       35G  4.3G   29G  13% /rhnsat
/dev/VG00/LogVol_var  5.8G  2.2G  3.4G  40% /var
/dev/VG00/LogVol_varsat
                       24G   16G  6.7G  70% /var/satellite
/dev/VG00/LogVol_optabe
                      9.9G  4.7G  5.1G  48% /opt/abe


 ###################### LogWatch End ######################### 

Additional info:

Comment 1 Patrick C. F. Ernzer 2005-06-19 07:16:12 UTC
forget the line "This happened for the first time on 2005-04-25. Previously the
display was not nice to look at but the info was there." above.

That is because prio entries were from a RHEL3 instance on that machine.

(That's what I get for having local e-mail centralised and keeping old logwatch
mails)

Comment 2 blbooth 2005-06-20 03:21:33 UTC
This was noticed back in December as bug 142863.

In /etc/log.d/scripts/services/zz-disk_space, try changing
df -h | grep '^/dev/'
to
df -h -P | grep '^/dev/'

This prints the numbers on the same line as the device name.


Comment 4 Jiri Ryska 2005-06-20 13:02:16 UTC

*** This bug has been marked as a duplicate of 152419 ***

Comment 5 Ivana Varekova 2005-07-29 11:42:44 UTC
*** Bug 164256 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.