Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160940 - anaconda bombs out on Sony Picturebook while "Reading package information"
Summary: anaconda bombs out on Sony Picturebook while "Reading package information"
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-19 00:16 UTC by Timothy Murphy
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-06 15:23:19 UTC


Attachments (Terms of Use)
The error dump provided during install on anaconda. I have the same problem (I'm doing fresh FC4 x86_64), happens in text/graphical mode, diskdruid or automatic. (deleted)
2005-09-05 23:29 UTC, Alec
no flags Details

Description Timothy Murphy 2005-06-19 00:16:11 UTC
Description of problem: anaconda bombs out on Sony Picturebook C1VFK during
hard disc upgrade to FC-4 from FC-3 while "Reading package information"


Version-Release number of selected component (if applicable):


How reproducible: 
Same result on second identical machine


Steps to Reproduce:
1. Try to upgrade from FC-3 to FC-4 on Sony Picturebook C1VFK/C1VE,
from hard disk.
2.
3.
  
Actual results:
Error message
========================================
An unhandled exception has occurred.  This
is most likely a bug.  Please copy the full
text of this exception and file a detailed
bug report against anaconda at
http://bugzilla.redhat.com/bugzilla/

Traceback (most recent call last)
  File "/usr/bin/anaconda", line 1160, in ?
    intf.run(id, dispatch)
  File "/usr/lib/anaconda/text.py", line
496, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py, line
174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py, line
242, in moveStep
    rc = apply(func, self.bindArgs(args))
========================================



Expected results:
Upgrade of system from FC-3 to FC-4

Additional info:
Exactly the same result on second identical machine.
Installation was from hard disk in both cases
(because of difficulty booting from CD on this machine).
System booted through grub, after transferring files in isolinux directory
on CD image to sub-directory of /boot .

Iso images checked with "linux mediacheck".

Comment 1 Jeremy Katz 2005-06-20 18:04:04 UTC
Can you provide the complete traceback you received?

Comment 2 Timothy Murphy 2005-06-21 12:15:47 UTC
You ask me for the complete traceback I received.

I already gave that in my bug report.
Here it is again:

========================================
An unhandled exception has occurred.  This
is most likely a bug.  Please copy the full
text of this exception and file a detailed
bug report against anaconda at
http://bugzilla.redhat.com/bugzilla/

Traceback (most recent call last)
  File "/usr/bin/anaconda", line 1160, in ?
    intf.run(id, dispatch)
  File "/usr/lib/anaconda/text.py", line
496, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py, line
174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py, line
242, in moveStep
    rc = apply(func, self.bindArgs(args))
========================================

I'm not sure what more you want.

Comment 3 Alec 2005-09-05 23:29:16 UTC
Created attachment 118480 [details]
The error dump provided during install on anaconda. I have the same problem (I'm doing fresh FC4 x86_64), happens in text/graphical mode, diskdruid or automatic.

The anacdump received in the error box.

Comment 4 Alec 2005-09-06 01:01:08 UTC
Oops. I guess my comments didn't get in there. I'm doing a fresh FC4 x86_64
(never installed before), and it happens right after the install.log info
screen, right before it starts installing packages...Thanks

Comment 5 Jeremy Katz 2005-09-06 15:23:19 UTC
There are multiple read errors from your CD.  Please be sure to verify your
installation media according to the instructions at
http://rhlinux.redhat.com/anaconda/mediacheck.html

Comment 6 Alec 2005-09-07 02:41:03 UTC
I checked cd #1 (the only one in the drive at the time) in the check tool on
boot, and it passed. I DID get around the problem - I used the preset
workstation install, and had no problems. Before, I was using my own custom
package selection. WOW. Fedora makes linux usable.

Comment 7 Alec 2005-09-08 18:46:07 UTC
FYI: ALL of my problems/fixes have been done NOT on a Sony Picturebook, but on
an Athlon64 box. My problem was specifically with the ananconda installer on
custom package selection from fc4 cds. Sorry if my previous posted information
(or lack thereof) confused you.


Note You need to log in before you can comment on or make changes to this bug.