Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160935 - FC4 installer failes to recognise /dev/sda on mpt-fusion
Summary: FC4 installer failes to recognise /dev/sda on mpt-fusion
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: FCMETA_INSTALL
TreeView+ depends on / blocked
 
Reported: 2005-06-18 23:00 UTC by Andrew Morton
Modified: 2015-01-04 22:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-30 09:24:46 UTC


Attachments (Terms of Use)

Description Andrew Morton 2005-06-18 23:00:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031030

Description of problem:
Dunno if this is a kernel bug or an installer bug.

I went to upgrade a standard Dell workstation from FC1 to FC4
but the installer acts like it's a fresh install.  When I
got to the point of doing the partitioning the installer tossed
up a dialog saying it couldn't read the partition table of sda
and then offered me sdb and hdb.

It looks like either the partition table scanner got confused or
the kernel is failing to access /dev/sda correctly.  Rather odd.

This machine does dual-boot Linux and XP so perhaps the partition table
parsing broke.  Tell me what command does that and I can have a play,
or can send you a copy of the partition table.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. INstall fc4
2.
3.
  

Additional info:

Comment 1 Dave Jones 2005-07-07 23:41:35 UTC
If you flip to tty2, is there anything out of the ordinary in dmesg ?

you should also have access to parted/fdisk from there, which should prove
interesting.


Comment 2 Dave Jones 2005-09-30 23:51:46 UTC
http://fedora.isphuset.no/ contains an unofficial Fedora 4.1, which may get you
up and running, as it has a install kernel based on one of the errata kernels.


Note You need to log in before you can comment on or make changes to this bug.