Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160934 - dhcp searches for ppp0 while eth0 gets connected
Summary: dhcp searches for ppp0 while eth0 gets connected
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rp-pppoe
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-18 22:01 UTC by Andrea Santilli
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-04-16 02:50:41 UTC


Attachments (Terms of Use)

Description Andrea Santilli 2005-06-18 22:01:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
This is what I get when I initialize my ethernet card (eth0):
Determinazione informazioni IP per eth0...ppp0: error fetching interface information: Device not found
ppp0: error fetching interface information: Device not found
ppp0: error fetching interface information: Device not found
External network device ppp0 is not ready. Aborting..
ppp0: error fetching interface information: Device not found
ppp0: error fetching interface information: Device not found
ppp0: error fetching interface information: Device not found
External network device ppp0 is not ready. Aborting..
 eseguito.

This happens even on boot.
I find this weird because ppp0 can't be connected until eth0 is (pppoe). So why does it look for ppp0 if it still hasn't initialized eth0?

The weirdest thing is that this doesn't create any problem in initialization of both eth0 and ppp0. Both still work fine.

Version-Release number of selected component (if applicable):
3.0.2-12

How reproducible:
Always

Steps to Reproduce:
1. /sbin/ifup eth0
2. I get the errors from ppp0
3. Though eth0 gets initialized and even ppp0 is ok when I start it.
  

Actual Results:  I get unusual ppp0 error while initializing eth0

Expected Results:  No error messages

Additional info:

This didn't use to happen in FC3.

Comment 2 Andrea Santilli 2006-03-29 00:15:18 UTC
Incredible, this bug is still present in FC5 and still marked as NEW

Comment 3 Ngo Than 2006-03-30 18:46:16 UTC
could you please attach the sysreport output? it's helpful for debugging. Thanks



Note You need to log in before you can comment on or make changes to this bug.