Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160933 - sound mixer external output default set to FALSE (Intel 82801 chipset)
Summary: sound mixer external output default set to FALSE (Intel 82801 chipset)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-utils
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
: 161308 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-18 21:41 UTC by Peter Quiring
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-11 14:01:08 UTC


Attachments (Terms of Use)
Output from command $ amixer > amixer.txt (deleted)
2005-06-29 22:47 UTC, Patrick Jon Cooney
no flags Details
Output of $ amixer > amixer.txt for desktop computer using emu10k1 driver (Audigy2) (deleted)
2005-06-29 23:36 UTC, Patrick Jon Cooney
no flags Details

Description Peter Quiring 2005-06-18 21:41:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
After a clean install, the mixer value for "External" is FALSE or Muted which causes sound to goto headphones.  Without knowing this I thought the sound driver just didn't work.
After browsing other bugs I heard a problem about muting the headphones would fix it.  Well, that didn't fix my problem, but if I unmuted "External" (external amplifier) (last option in alsamixer) it works.
So just thought it would be nice if "External" by default is not muted for my chipset.

Card : Intel 82801DB-ICH4
Chipset : SigmaTel STAC9750,51

Thanks.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install FC4
2.play sound
3.sound coming out headphones by default
  

Actual Results:  sound comes out headphones by default (regardless if headphones are plugged in)

Expected Results:  sound out speakers by default

Additional info:

Comment 1 Martin Stransky 2005-06-20 16:11:31 UTC
Could you please attach output of "amixer"?

Comment 2 Peter Quiring 2005-06-23 01:40:42 UTC
Output of amixer (while "External" is Muted):

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 25 [81%] [on]
  Front Right: Playback 25 [81%] [on]
Simple mixer control 'Master Mono',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 23 [74%] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on]
  Front Right: Playback 23 [74%] [on]
Simple mixer control '3D Control - Center',0
  Capabilities: volume volume-joined
  Playback channels: Mono
  Limits: 0 - 15
  Mono: 0 [0%]
Simple mixer control '3D Control - Depth',0
  Capabilities: volume volume-joined
  Playback channels: Mono
  Limits: 0 - 15
  Mono: 0 [0%]
Simple mixer control '3D Control - Switch',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on]
  Front Right: Playback 23 [74%] [on]
Simple mixer control 'PCM Out Path & Mute',0
  Capabilities:
  Mono:
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined
cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 0 [0%] [off] Capture [off]
  Front Right: Playback 0 [0%] [off] Capture [off]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined
cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on] Capture [on]
  Front Right: Playback 23 [74%] [on] Capture [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch
cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono: Playback 0 [0%] [off]
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Mic Boost (+20dB)',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Mic Select',0
  Capabilities:
  Mono:
Simple mixer control 'Video',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined
cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 0 [0%] [off] Capture [off]
  Front Right: Playback 0 [0%] [off] Capture [off]
Simple mixer control 'Phone',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch
cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono: Playback 0 [0%] [off]
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'PC Speaker',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 15
  Mono: Playback 11 [73%] [on]
Simple mixer control 'Aux',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined
cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 0 [0%] [off] Capture [off]
  Front Right: Playback 0 [0%] [off] Capture [off]
Simple mixer control 'Mono Output Select',0
  Capabilities:
  Mono:
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 0 [0%] [off]
  Front Right: Capture 0 [0%] [off]
Simple mixer control 'Mix',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Mix Mono',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]

Comment 3 Peter Quiring 2005-06-23 01:43:24 UTC
Also, I forgot to mention that plugging in the headphones doesn't
auto-sense and switch to headphones.  You have to control the
"External" option manually (it controls headphones/speakers).


Comment 4 Martin Stransky 2005-06-29 09:34:53 UTC
*** Bug 161308 has been marked as a duplicate of this bug. ***

Comment 5 Patrick Jon Cooney 2005-06-29 22:47:27 UTC
Created attachment 116154 [details]
Output from command $ amixer > amixer.txt

Comment 6 Patrick Jon Cooney 2005-06-29 22:51:07 UTC
Woops: above comment should clarify my attachment.  I had same problems as 
described in this bug for a laptop (with intel8x0 driver) and a desktop (with 
the audigy2/sound blaster driver).  

A clean install of FC4 were done on both computers.  Both installs seemingly 
detected these devices, except no sound is heard when enabled in window 
manager.  

Unmuting external device in alsa mixer works for the laptop and I expect for 
the desktop too.

Attachment above is from the laptop.

Comment 7 Patrick Jon Cooney 2005-06-29 23:34:52 UTC
So much for expectations ... :)

I can hear sound through the headphone jack of the desktop, but using alsamixer
I can't do the same as I did with the laptop.  For starters there is no
'external' option.  Thinking that the emu10k1 sees headphones as the line input,
I muted those too.  (This was not possible in alsamixer, I had to you GNOME's
volume control, enable the list of available devices and mute the line inputs
that way.)

No joy.

Attachement of amixer follows ...

Comment 8 Patrick Jon Cooney 2005-06-29 23:36:07 UTC
Created attachment 116156 [details]
Output of $ amixer > amixer.txt for desktop computer using emu10k1 driver (Audigy2)


Note You need to log in before you can comment on or make changes to this bug.