Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160924 - permission denied for cd/dvd device
Summary: permission denied for cd/dvd device
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: hdparm
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-18 18:41 UTC by Gérard Milmeister
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-27 12:21:19 UTC


Attachments (Terms of Use)

Description Gérard Milmeister 2005-06-18 18:41:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21

Description of problem:
hdparm (root)  works fine for HD devices, but on /dev/hdd which
is a DVD device, it only says:
/dev/hdd: Permission denied

I tried hdparm-6.1 which works fine as before.

Version-Release number of selected component (if applicable):
hdparm-5.9-1

How reproducible:
Always

Steps to Reproduce:
1. As root: /sbin/hdparm /dev/cdrom
2. Returns: /dev/cdrom: Permission denied

  

Additional info:

Comment 1 Karsten Hopp 2005-06-23 09:26:10 UTC
what are the permissions of /dev/cdrom or if it is a link the device file it
points at ?

Comment 2 Gérard Milmeister 2005-06-23 17:29:08 UTC
Now it works again. After rebooting I couldn't reproduce the problem...
But maybe there is a bug deeply hidden that only shows under certain unlikely
circumstances.

Comment 3 Karsten Hopp 2005-06-27 12:21:19 UTC
closing based on last comment. This looks more like a udev problem anyway. (udev
creates the device files in /dev) 


Note You need to log in before you can comment on or make changes to this bug.