Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160922 - ldconfig update crashes kicker when ksim is running (under kde3.3)
Summary: ldconfig update crashes kicker when ksim is running (under kde3.3)
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kdeutils
Version: 4.0
Hardware: i386
OS: Linux
Target Milestone: ---
: ---
Assignee: Ngo Than
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2005-06-18 18:08 UTC by Jason Boisvert
Modified: 2010-12-16 16:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2010-12-16 16:20:43 UTC
Target Upstream Version:

Attachments (Terms of Use)

Description Jason Boisvert 2005-06-18 18:08:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
ldconfig update crashes kicker when ksim is running (under kde3.3)

If ksim is running under kde3.3 and ldconfig is called and an update is required, 
kicker crashes. It seems to happen everytime an rpm calls ldconfig or if ldconfig is called manually and makes an update. (If no update is needed, kicker won't crash.)

If you turn off ksim, the problem stops.

Version-Release number of selected component (if applicable):
kde 3.3

How reproducible:

Steps to Reproduce:
1.start ksim -- I ran with hd, net and cpu modules
2.install rpm, probably one that installs a library (I'm not sure about this) ldconfig -- or if ldconfig runs as a part of the rpm

Actual Results:  the kicker crashed several times.

Expected Results:  Nothing should have happened accept the installation of the program. 
This does not happen when ksim is not running.

Additional info:

It only occurs when ksim is running and can be fixed by turning off ksim.

Comment 1 Ngo Than 2005-07-07 09:50:04 UTC
I'm able to reproduce this bug on my machine. It seems a bug in kdebase.

Comment 2 Ngo Than 2005-07-07 11:38:57 UTC
strange, it did happen by first time when i started ldconfig manually,
but after that it does not crash anymore when i tried to start ldconfig manually
or installed some libs packages which start ldconfig!

Could you still reproduce this bug ?

Comment 3 Jason Boisvert 2005-07-07 12:55:44 UTC
I can still reproduce the bug under FC3. I have cpu and net modules running on
The crash reproduces anytime ldconfig actually runs -- but installing new
libraries should trigger that. I got it to crash by installing a random rpm.
If you want me to try other scenarios, I can.

Comment 4 Ngo Than 2005-07-07 14:17:41 UTC
yes, please. It's very helpful for debugging if i can get the backtrace.

Could you please install kdelibs/kdebase/kdeutils debuginfos packages and then
try to get the backtrace. Thanks

Comment 5 Jason Boisvert 2005-07-07 15:29:57 UTC
Alright. Give me a day or two.

Comment 6 Jason Boisvert 2005-07-08 05:10:31 UTC
here is the backtrace after I installed the recommended rpms.

Using host libthread_db library "/lib/tls/".
[Thread debugging using libthread_db enabled]
[New Thread -1208613184 (LWP 4515)]
[KCrash handler]
#4  0x0056e876 in CpuView::updateView () from /usr/lib/kde3/
#5  0x0056eb1c in CpuView::qt_invoke () from /usr/lib/kde3/
#6  0x05ff310e in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/
#7  0x05ff37e4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/
#8  0x063278dd in QTimer::timeout () from /usr/lib/qt-3.3/lib/
#9  0x06012ebc in QTimer::event () from /usr/lib/qt-3.3/lib/
#10 0x05f94539 in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/
#11 0x05f946ca in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/
#12 0x0033f3f8 in KApplication::notify () from /usr/lib/
#13 0x05f888ab in QEventLoop::activateTimers ()
   from /usr/lib/qt-3.3/lib/
#14 0x05f446fe in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/
#15 0x05fa9b85 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/
#16 0x05fa9ade in QEventLoop::exec () from /usr/lib/qt-3.3/lib/
#17 0x05f9373b in QApplication::exec () from /usr/lib/qt-3.3/lib/
#18 0x0016306e in kdemain () from /usr/lib/
#19 0x00d746b0 in kdeinitmain () from /usr/lib/kde3/
#20 0x0804dfb1 in ?? ()
#21 0x00000001 in ?? ()
#22 0x09096c28 in ?? ()
#23 0x00000001 in ?? ()
#24 0x09096a17 in ?? ()
#25 0x00000000 in ?? ()

Comment 7 Ngo Than 2005-07-14 14:13:13 UTC
needing some infos, are you using SMP kernel? is hyperthreading enable?

Comment 8 Ngo Than 2005-07-14 14:47:14 UTC
I will upload new kdeutils-3.3.1-2.2 on today.
It should fix this problem in ksim. It would be nice if you could test it please. 


Comment 9 Jason Boisvert 2005-07-14 14:51:23 UTC
I will test it.
I am on a laptop and don't have smp running. It's a centrino M processor with no

Comment 10 Ngo Than 2005-07-14 15:00:58 UTC
it's now available on you can download it

Comment 11 Jason Boisvert 2005-07-14 16:51:03 UTC
I installed kdeutils and rebooted.
I ran my ati-fglrx driver installation rpm and kicker crashed.

Here is the backtrace.

Using host libthread_db library "/lib/tls/".
[Thread debugging using libthread_db enabled]
[New Thread -1208736064 (LWP 4506)]
[KCrash handler]
#4  0x001bd876 in CpuView::updateView () from /usr/lib/kde3/
#5  0x001bdb1c in CpuView::qt_invoke () from /usr/lib/kde3/
#6  0x0601b10e in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/
#7  0x0601b7e4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/
#8  0x0634f8dd in QTimer::timeout () from /usr/lib/qt-3.3/lib/
#9  0x0603aebc in QTimer::event () from /usr/lib/qt-3.3/lib/
#10 0x05fbc539 in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/
#11 0x05fbc6ca in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/
#12 0x002ca3f8 in KApplication::notify () from /usr/lib/
#13 0x05fb08ab in QEventLoop::activateTimers ()
   from /usr/lib/qt-3.3/lib/
#14 0x05f6c6fe in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/
#15 0x05fd1b85 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/
#16 0x05fd1ade in QEventLoop::exec () from /usr/lib/qt-3.3/lib/
#17 0x05fbb73b in QApplication::exec () from /usr/lib/qt-3.3/lib/
#18 0x0049b06e in kdemain () from /usr/lib/
#19 0x0012d6b0 in kdeinitmain () from /usr/lib/kde3/
#20 0x0804dfb1 in ?? ()
#21 0x00000001 in ?? ()
#22 0x09a09688 in ?? ()
#23 0x00000001 in ?? ()
#24 0x09abe767 in ?? ()
#25 0x00000000 in ?? ()

Comment 12 Ngo Than 2005-07-14 17:03:30 UTC
I forget to apply the patch, and it should still crash of course. sorry for this!
I will upload new kdeutils-3.3.1-2.3 in next 10 minutes. Please try again.
Many thanks for testing.

Comment 13 Ngo Than 2005-07-14 17:15:00 UTC
kdeutils-3.3.1-2.3 is now available on

Comment 14 Jason Boisvert 2005-07-14 21:46:36 UTC
That seems to have fixed it. 
I tried twice and both times it was fine.

Comment 15 Ngo Than 2005-07-15 09:14:59 UTC
if we do update it for RHEL4, this will be included. Many thanks for your  

Comment 18 Suzanne Yeghiayan 2010-12-16 16:20:43 UTC
Unfortunately this issue did not get resolved in RHEL 4.9.
If this is still a concern, please contact your Red Hat Support representative to request an exception.

Note You need to log in before you can comment on or make changes to this bug.