Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160917 - gda-postgres has bad dependency info
Summary: gda-postgres has bad dependency info
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgda
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-18 15:31 UTC by Michael Tiemann
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.2.0-6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-21 09:05:18 UTC


Attachments (Terms of Use)

Description Michael Tiemann 2005-06-18 15:31:14 UTC
Description of problem:

The gda-postgres component is advertised as a Fedora Extras component, but is
not listed, so I'm filing against what I believe is a related package.

Version-Release number of selected component (if applicable):

1.2.0, release 5


How reproducible:


Steps to Reproduce:
1. Install FC4
2. Run up2date (no options) and select all packages
3. ...or run yum update (no options) and let it run
  
Actual results:

Both up2date and yum think they are happy with updating gda-postgres, but when
they try to run the transaction tests, they find a dependence on libpq.so.3 that
they cannot resolve.  Neither of them can figure out what package is supposed to
satisfy this dependency.  Both abort.

Expected results:


Additional info:

Comment 1 Michael Schwendt 2005-06-18 20:26:16 UTC
libgda has not been rebuilt after postgres jumped to .so.4 in Rawhide.

[Bugzilla component "libgda" is correct, because it's common practice to use the
src.rpm name for bugzilla components. The unusual thing about it, which I
believe is a bug and an unfortunate choice of package names, are the
sub-packages: gda-mysql, gda-odbc, gda-postgres -- these depend on their mother
package "libgda" and extend it with plugins. Naming them "libgda-mysql,
libgda-odbc, libgda-postgres" would have been better.]


Comment 2 Hans de Goede 2005-06-19 16:53:22 UTC
1) Are we talking about Extras for FC4 or extras for rawhide?
   Michael you're talking about Rawhide, but the bug is filed against 4.

2) About changing the names, I agree, how would I do that?
   Provides and Conflicts with the old names? Should I do anything with
   version no's in the Provides and Conflicts?


Comment 3 Michael Schwendt 2005-06-19 17:26:26 UTC
For this one, rawhide = fedora core 4 development, of course (fc5 is far far
away and rather unimportant at this point in time).

No "Conflicts"! Package renaming should be done via:

  Obsoletes: oldname < %{version}-%{release}
  Provides: oldname = %{version}-%{release}

The corresponding versioned "Provides" for the %{name} is implicit/automatic.

Comment 4 Hans de Goede 2005-06-21 09:05:18 UTC
I've requested a rebuild for FC-4 which should result in libgda-1.2.0-5.1

For devel I've changed the names for the database providers from gda-xxx to
libgda-xxx and requested a built which should result in libgda-1.2.0-6

Closing.


Note You need to log in before you can comment on or make changes to this bug.