Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160911 - anaconda fails to upgrade with bind mounts in fstab
Summary: anaconda fails to upgrade with bind mounts in fstab
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-18 13:01 UTC by Eric Harney
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-08 19:22:29 UTC


Attachments (Terms of Use)
fstab from previous (and current) system (deleted)
2005-06-24 21:58 UTC, Eric Harney
no flags Details

Description Eric Harney 2005-06-18 13:01:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I was upgrading from FC3 to FC4.  My current fstab included entries such as:

/dev/hdc1       /mnt/storage1   reiserfs        defaults        0 0
/mnt/storage1    /home/files/storage1          none    bind    0 0


This fails to mount in the installer because (if I remember correctly), entries from the fstab on the system are mounted under the /mnt/sysimage root, and not /, so /mnt/storage1 would not exist.  Anaconda determines from this that it couldn't mount everything it needed to, and forces you to quit and reboot.

My workaround was to boot FC3 again and remove the bind mount entries temporarily, then install.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.  FC3 system with bind mounts configured in fstab
2.  Boot FC4 dvd and try to upgrade.

Actual Results:  Anaconda forces the user to exit.

Expected Results:  Not sure what the best solution is - in my case, simply not mounting bind mounts in the first place would have sufficed.  I'm not sure if this generalizes to others, but there needs to be a way for users with this setup to install.

Additional info:

Comment 1 Chris Lumens 2005-06-20 18:47:46 UTC
This works with ext3 partitions.  Are you booting with "linux reiserfs"?

Comment 2 Eric Harney 2005-06-20 21:59:17 UTC
No, I didn't boot with "linux reiserfs".

However, it seems unreasonable that I should have to in this scenario -- It was
able to mount my old root partition, which was also reiserfs, to read the fstab
off of it, so I think something else is going on here.  If it can mount the old
root there's no reason it shouldn't be able to mount the other partitions as well.

Comment 3 Chris Lumens 2005-06-21 19:02:10 UTC
What was the exact error message you got?

Comment 4 Chris Lumens 2005-06-21 20:32:17 UTC
This works for me.  Can you also provide your /tmp/anacdump.txt file (if you
have one), /tmp/anaconda.log, and the fstab from your installed system?

Comment 5 Eric Harney 2005-06-24 21:56:52 UTC
Those files do not exist on my system.  (I actually checked a few days ago and
they weren't there then either, so I guess they just didn't get logged.  Sorry
for the long wait.)

Will attach fstab.

Comment 6 Eric Harney 2005-06-24 21:58:16 UTC
Created attachment 115960 [details]
fstab from previous (and current) system

Comment 7 David Cantrell 2006-02-08 19:22:29 UTC
Bind mounts were mounted in rawhide, but the order was incorrect.  After a few
test runs, I think I have it working.  Changes committed to cvs.


Note You need to log in before you can comment on or make changes to this bug.