Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160901 - x server does not start. cannot use graphical install. 1 line block pattern at top of display
Summary: x server does not start. cannot use graphical install. 1 line block pattern ...
Keywords:
Status: CLOSED DUPLICATE of bug 160420
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-18 08:27 UTC by Shane Walters
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-11 15:48:25 UTC


Attachments (Terms of Use)
configuration file (deleted)
2005-06-18 08:29 UTC, Shane Walters
no flags Details

Description Shane Walters 2005-06-18 08:27:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When I try to do a graphical install I get scrambled output on the monitor.  Even after a text install when firstboot starts same problem.  I cannot get the x server to start at all.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-37 kernel-2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
1. Fresh install or upgrade on dell poweredge SC420 to FC4
2. anything that requires the use of the X server or any graphical environment 
3. 
  

Actual Results:  Scramble output on one line at top on screen about 5 colored boxes in a 1/2" band.

Expected Results:  I should have been able to start x or perform a clean graphical install.

Additional info:

Comment 1 Shane Walters 2005-06-18 08:29:06 UTC
Created attachment 115650 [details]
configuration file

A copy of my current xorg configuration file.

Comment 2 Shane Walters 2005-06-18 08:36:15 UTC
This occurs on a Dell Poweredge Server SC420

Comment 3 Mike A. Harris 2005-06-22 21:35:36 UTC
Please review bug number 161242 everyone, and try using the libvgahw.a module
that is linked to from that bug report.  This is just a hunch I'd like
to test to see if the problem reported on Matrox and Intel hardware is also
causing problems on Trident and other hardware.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161242

Anyone who can test this and provide feedback, would be greatly appreciated.

Thanks in advance.

Comment 4 Shane Walters 2005-07-08 01:32:32 UTC
Tested with the module listed in the other bug but still had the same problem. 
But when used in conjuction with the lastest intel driver (obtained here
http://www.fairlite.demon.co.uk/i810_drv.o) I got X to start and work fine.

Can someone try this combination (1 or both) and see if this is the solution.

Comment 5 nw 2005-07-11 15:29:20 UTC
Also ran into the problem of using the integrated intel E7221 graphics on the
sc420 with FC4, geting several little "boxes" with random colors in a straight
line across the screen near the top. Frustrating! Worked in FC3. Hope someone
can fix it and update the distro.

In forum (url below) user "UnixVRules" reported it works with the i820 driver
you linked to above. I haven't tried it, myself, yet (but intend to):
http://forums.fedoraforum.org/printthread.php?t=59127&pp=80

UnixVRules said:
"I downloaded the i810_drv.o file, dropped it into
/usr/X11R6/lib/modules/drivers/i810_drv.o
and then restarted X (I just issued a kill -HUP to gdm)."

his xorg.conf contains:
----------
Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 915"
Option "noaccel"
EndSection
----
he later reported it works faster without the line "Option "noaccel" and was
looking for feedback from others on that.
----
hope this helps -nw
keep up the good work.

Comment 6 Olivier Baudron 2005-07-30 13:30:04 UTC
Can you test xorg-x11-6.8.2-44 and see if it fixes your problem.

Comment 7 Olivier Baudron 2005-08-11 15:48:25 UTC

*** This bug has been marked as a duplicate of 160420 ***


Note You need to log in before you can comment on or make changes to this bug.