Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160898 - Installed GPG key is not the correct one
Summary: Installed GPG key is not the correct one
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: autoconf
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-18 07:15 UTC by axgrau
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-19 13:02:50 UTC


Attachments (Terms of Use)

Description axgrau 2005-06-18 07:15:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I can't install autoconf because I get the error that the GPG key installed is not the correct one. Removing and reinstalling the key didn't help. I can install other packages from base.

Version-Release number of selected component (if applicable):
autoconf-2.59-5.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1.yum install automake
2.
3.
  

Actual Results:  warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID db42a60e
public key not available for autoconf-2.59-5.noarch.rpm
Retrieving GPG key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

The GPG key at file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora (0x4F2A6FD2)
is already installed but is not the correct key for this package.
Check that this is the correct key for the "Fedora Core 4 - i386 - Base" repository.

Additional info:

Comment 1 Karsten Hopp 2005-07-19 13:02:50 UTC
you need to import /etc/pki/rpm-gpg/RPM-GPG-KEY


Note You need to log in before you can comment on or make changes to this bug.