Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160893 - Unable to obtain the right resolution for DVI panel
Summary: Unable to obtain the right resolution for DVI panel
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
: 160869 162020 203218 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2005-06-18 05:25 UTC by xavier.loup
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-06-27 16:03:03 UTC

Attachments (Terms of Use)
xorg configuration file (deleted)
2005-10-26 08:16 UTC, xavier.loup
no flags Details
xorg log file (deleted)
2005-10-26 08:18 UTC, xavier.loup
no flags Details

System ID Priority Status Summary Last Updated 3654 None None None Never

Description xavier.loup 2005-06-18 05:25:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I have a Sony HX93 monitor with a DVI connection.
The right resolution for this monitor is 1280 x 1024.

With Fedora Core 3, I could use this resolution without any trouble.
With Fedora Core 4, this resolution is unavailable.

I have tried with the nv and nvidia driver.
I have tried using "Sony SDM-HX93" monitor and "LCD panel 1280x1024"

system-config-display let me choose a resolution of 1280x1024.
gnome-display-properties don't let me choose a resolution of 1280x1024.

Xorg.log file :
(II) NV(0): Mode "1280x1024" is larger than BIOS programmed panel size of 1024 x 768.  Removing.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Open gnome-display-properties.
2. Try to choose 1280x1024
3. Only 1024x768 (or smaller) resolution is avalaible

Additional info:

Comment 1 xavier.loup 2005-06-18 05:27:44 UTC
I made a mistake : The problem is only with nv driver. Nvidia binary driver
works OK.

Comment 2 Mike A. Harris 2005-06-23 19:21:22 UTC
The line:

(II) NV(0): Mode "1280x1024" is larger than BIOS programmed panel size of 1024 x
768.  Removing.

Indicates that your BIOS claims the panel size is 1024x768, so this appears to
be a BIOS bug.  Have you recently updated your BIOS?

Make sure you do not have the proprietary Nvidia drivers even installed, as
they overwrite Red Hat supplied X server modules, resulting in an unsupported
installation.  Reinstall all xorg-x11 rpms if you have installed nvidia
proprietary drivers previously, in order to restore the Red Hat supplied
modules and ensure a clean install.

If that does not solve the problem, please report the issue to X.Org at in the "xorg" component, and paste the URL
here and we will track the issue in the upstream bugzilla.

Thanks in advance.

Comment 3 xavier.loup 2005-06-29 07:29:36 UTC
I have created a bug report in X.Org bugzilla :

Comment 4 Olivier Baudron 2005-07-31 07:36:19 UTC
xorg-x11-6.8.2-45 fixed a bios related issue: linux-native-pciscan patch was 
broken. Can you give it a try?

Comment 5 Olivier Baudron 2005-07-31 08:20:05 UTC
*** Bug 162020 has been marked as a duplicate of this bug. ***

Comment 6 Mindy Preston 2005-08-17 15:19:18 UTC
I am seeing this bug with a Dell 2405FP connected through DVI and
xorg-x11-6.8.2-45 did not fix it.

Comment 7 Olivier Baudron 2005-08-17 15:30:29 UTC
In reply to comment #3:

> I have created a bug report in X.Org bugzilla :

Please update your report there, because it is currently void (except for the

In reply to comment #6:

> xorg-x11-6.8.2-45 did not fix it

Is -37 the last version known to work for this issue ?

Comment 8 Olivier Baudron 2005-08-17 15:58:24 UTC
Can someone having this problem attach his /var/log/Xorg.0.log ?

Comment 9 Walter Justen 2005-08-26 10:14:52 UTC
*** Bug 160869 has been marked as a duplicate of this bug. ***

Comment 10 xavier.loup 2005-10-26 08:15:38 UTC
This big is still present with xorg-x11-6.8.2-37.FC4.49.2

I'll attach my xorg.conf and Xorg.0.log files

Comment 11 xavier.loup 2005-10-26 08:16:58 UTC
Created attachment 120400 [details]
xorg configuration file

Current xorg configuration file

Comment 12 xavier.loup 2005-10-26 08:18:06 UTC
Created attachment 120401 [details]
xorg log file

Current xorg log file

Comment 13 Mike A. Harris 2006-06-27 16:03:03 UTC
The upstream bug report indicates that this is not something that can be
fixed currently:

Closing as "CANTFIX".  If they are able to provide a fix in the future
however, and it makes it into an X.Org release, it will appear in a future
Fedora release.

Comment 14 Scott Lamb 2006-08-19 06:40:04 UTC
*** Bug 203218 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.