Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160887 - extract always to a subdirectory
Summary: extract always to a subdirectory
Keywords:
Status: CLOSED DUPLICATE of bug 160703
Alias: None
Product: Fedora
Classification: Fedora
Component: file-roller
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-18 01:38 UTC by Richard S. Hendershot
Modified: 2013-03-06 03:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-23 01:18:07 UTC


Attachments (Terms of Use)

Description Richard S. Hendershot 2005-06-18 01:38:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
opt is a bookmark & has subdir X. Setting focus to various buttons or rows; nothing helped.  Extracts to X always.  Makes file-roller unusable if extracting to a parent directory or seemingly any random dir with a child.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.root user was a tar of its home from FC3
open 'Computer - File Browser'
click on 'Filesystem'
navigate to a .gz file and double click it [/home/share/filename.tar.gz]
click Etract
[file dialog displays current directory)
click 'Extract'
file created in directory below current directory

2.do again with another user
user was a tar of its home from FC3

3.
  

Actual Results:  both root and dev_user created file in sub of current directory - FAIL

Expected Results:  file created in current directory

Additional info:

creating file in parent (eg. home) allows all users to use it. SECURITY

Comment 1 Marc Deslauriers 2005-07-23 01:18:07 UTC

*** This bug has been marked as a duplicate of 160703 ***


Note You need to log in before you can comment on or make changes to this bug.