Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160885 - eclipse failed to install (claiming bogus missing dependencies)
Summary: eclipse failed to install (claiming bogus missing dependencies)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-18 00:51 UTC by Peter Williams
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-29 19:00:55 UTC


Attachments (Terms of Use)

Description Peter Williams 2005-06-18 00:51:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Attempts to install eclipse using both the package administration GUI and yum failed with several "missing dependency" messages.  Checks of the objects complained of in the "missing dependency" messages indicate that they are (in fact) installed on the system.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. As root do: yum install eclipse
2.
3.
  

Actual Results:  --> Finished Dependency Resolution
Error: Missing Dependency: commons-collections = 2.1-12 is needed by package commons-collections-devel
Error: Missing Dependency: commons-digester = 1.4.1-13 is needed by package commons-digester-devel
Error: Missing Dependency: lib-org-apache-commons-collections-2.1.so is needed by package commons-pool
Error: Missing Dependency: commons-modeler = 1.0-8 is needed by package commons-modeler-devel
Error: Missing Dependency: lib-org-apache-commons-collections-2.1.so is needed by package commons-dbcp
Error: Missing Dependency: commons-collections >= 2.1-12 is needed by package commons-dbcp
Error: Missing Dependency: commons-collections >= 2.1-12 is needed by package commons-pool
Error: Missing Dependency: commons-beanutils = 1.6.1-13 is needed by package commons-beanutils-devel
Error: Missing Dependency: lib-javax-xml-transform-2.4.1.so is needed by package mx4j-tools
Error: Missing Dependency: xalan-j >= 2.4.1-14 is needed by package mx4j-tools
[

Expected Results:  Successful installation

Additional info:

[peterw@heathwren ~]$ rpm -q commons-collections commons-digester commons-modeler commons-beanutils xalan-j
commons-collections-2.1-12
commons-digester-1.4.1-13
commons-modeler-1.0-8
commons-beanutils-1.6.1-13
xalan-j-2.4.1-14
[peterw@heathwren ~]$ ls -l /usr/lib/lib-javax-xml-transform-2.4.1.so -rwxr-xr-x  1 root root 90324 May  5  2004 /usr/lib/lib-javax-xml-transform-2.4.1.so
[peterw@heathwren ~]$ ls -l /usr/lib/lib-org-apache-commons-collections-2.1.so -rwxr-xr-x  1 root root 753252 May  5  2004 /usr/lib/lib-org-apache-commons-collections-2.1.so
[peterw@heathwren ~]$

Comment 1 Peter Williams 2005-06-24 01:36:29 UTC
It looks like this is NOT an eclipse specific problem but a general
rpm/yum problem as I got the same errors when I tried to do an update.

Further this only happens on one of my machines (as luck would have it the first
one I tried) and the others seem to be OK.  I've tried rebuilding the rpm data
base to no avail.  Is there something else that I should try?

Comment 2 Peter Williams 2005-06-27 00:20:55 UTC
I have been able to work around this problem by removing the following packages
by hand:

commons-modeler-devel
commons-collections-devel
mx4j-tools
commons-beanutils-devel
commons-fileupload-devel
commons-digester-devel
commons-dbcp-devel
commons-pool-devel
javamail-devel

Comment 3 Jeff Johnson 2005-06-27 00:35:30 UTC
Yum chose the packages to install, and filled the transaction set that rpmlib installed, so this is no rpm 
problem. Changing component ...

Comment 4 Seth Vidal 2005-07-29 19:00:55 UTC
I think you're just reading the error messages backward.

see this:
https://lists.dulug.duke.edu/pipermail/yum/2005-July/006994.html

It's linked from the yumfaq here:
http://wiki.linux.duke.edu/YumFaq

thanks



Note You need to log in before you can comment on or make changes to this bug.