Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160877 - Missing rlm_ldap.so in FC4 RPM?
Summary: Missing rlm_ldap.so in FC4 RPM?
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: freeradius
Version: 4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
: 163072 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 22:27 UTC by Jeffrey Haas
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version: 1.0.4-1.FC4.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-31 13:38:21 UTC


Attachments (Terms of Use)

Description Jeffrey Haas 2005-06-17 22:27:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
/usr/lib/rlm_ldap.so seems to be missing in the freeradius RPM included with Fedora core 4.  

Please pardon the bother if it has been moved to another package.  I searched but couldn't find it.

Version-Release number of selected component (if applicable):
freeradius 1.0.2-2

How reproducible:
Always

Steps to Reproduce:
1. rpm -qa freeradius | grep -i ldap
2. ls -l /usr/lib/rlm_ldap*
3.
  

Additional info:

Comment 1 Thibault LE MEUR 2005-06-29 16:43:00 UTC
I confirm that the rlm_ldap.so file is not present and nowhere to be found in 
the new FC4 packages. It seems that freeradius wasn't compiled with the ldap 
librairies.

As a workaround, you can copy an rlm_ldap.so file from a FC3 distribution 
to /usr/lib/rlm_ldap.so.

I'm waiting for an updated freeradius package or a new freeradius-ldap package.


Comment 2 Victoriano Giralt 2005-06-30 10:03:21 UTC
To add insult to injury, the .src.rpm package does not compile. The rpmbuild
process crashes big time with:
-----------------------------------
Making static dynamic in rlm_eap...
gmake[6]: Entering directory
`/usr/src/redhat/BUILD/freeradius-1.0.2/src/modules/rlm_eap'
gcc  -O2 -g -march=i386 -mcpu=i686 -fpic -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS
-DOPENSSL_NO_KRB5   -Wall -D_GNU_SOURCE -DNDEBUG  -I../../include  -I./libeap -c
rlm_eap.c -o rlm_eap.o
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
In file included from rlm_eap.c:26:
rlm_eap.h:26:18: error: ltdl.h: No such file or directory
In file included from rlm_eap.c:26:
rlm_eap.h:36: error: syntax error before âlt_dlhandleâ
rlm_eap.h:36: warning: no semicolon at end of struct or union
rlm_eap.h:39: error: syntax error before â}â token
rlm_eap.h:39: warning: type defaults to âintâ in declaration of âEAP_TYPESâ
rlm_eap.h:39: warning: data definition has no type or storage class
rlm_eap.h:51: error: syntax error before âEAP_TYPESâ
rlm_eap.h:51: warning: no semicolon at end of struct or union
rlm_eap.h:66: error: syntax error before â}â token
rlm_eap.h:66: warning: type defaults to âintâ in declaration of ârlm_eap_tâ
rlm_eap.h:66: warning: data definition has no type or storage class
rlm_eap.h:70: error: syntax error before â*â token
rlm_eap.h:71: error: syntax error before â*â token
rlm_eap.h:72: error: syntax error before â*â token
rlm_eap.h:75: error: syntax error before â*â token
rlm_eap.h:79: error: syntax error before â*â token
rlm_eap.h:89: error: syntax error before â*â token
rlm_eap.h:90: error: syntax error before â*â token
rlm_eap.h:91: error: syntax error before â*â token
rlm_eap.c:33: error: syntax error before ârlm_eap_tâ
rlm_eap.c:35: error: syntax error before ârlm_eap_tâ
rlm_eap.c:37: error: syntax error before ârlm_eap_tâ
rlm_eap.c:39: error: syntax error before ârlm_eap_tâ
rlm_eap.c: In function âeap_detachâ:
rlm_eap.c:55: error: âinstâ undeclared (first use in this function)
rlm_eap.c:55: error: (Each undeclared identifier is reported only once
rlm_eap.c:55: error: for each function it appears in.)
rlm_eap.c:55: error: invalid operands to binary *
rlm_eap.c:55: warning: statement with no effect
rlm_eap.c:58: error: syntax error before â)â token
rlm_eap.c:63: error: âstruct CONF_PARSERâ has no member named âtypesâ
rlm_eap.c:63: error: used struct type value where scalar is required
rlm_eap.c:63: error: âstruct CONF_PARSERâ has no member named âtypesâ
rlm_eap.c:64: error: âstruct CONF_PARSERâ has no member named âtypesâ
rlm_eap.c:64: error: assignment of read-only location
rlm_eap.c:64: error: incompatible types in assignment
rlm_eap.c:64: warning: statement with no effect
rlm_eap.c:68: error: âstruct CONF_PARSERâ has no member named âsession_mutexâ
rlm_eap.c:68: warning: passing argument 1 of âpthread_mutex_destroyâ from
incompatible pointer type
rlm_eap.c:69: error: âstruct CONF_PARSERâ has no member named âmodule_mutexâ
rlm_eap.c:69: warning: passing argument 1 of âpthread_mutex_destroyâ from
incompatible pointer type
rlm_eap.c:72: error: âstruct CONF_PARSERâ has no member named
âdefault_eap_type_nameâ
rlm_eap.c:72: error: âstruct CONF_PARSERâ has no member named
âdefault_eap_type_nameâ
rlm_eap.c:72: warning: passing argument 1 of âfreeâ discards qualifiers from
pointer target type
rlm_eap.c:73: warning: passing argument 1 of âfreeâ discards qualifiers from
pointer target type
rlm_eap.c: In function âeap_instantiateâ:
rlm_eap.c:87: error: âinstâ undeclared (first use in this function)
rlm_eap.c:87: error: invalid operands to binary *
rlm_eap.c:87: warning: statement with no effect
rlm_eap.c:89: error: syntax error before â)â token
rlm_eap.c:93: warning: passing argument 1 of âmemsetâ discards qualifiers from
pointer target type
rlm_eap.c:94: warning: passing argument 2 of âcf_section_parseâ discards
qualifiers from pointer target type
rlm_eap.c:95: warning: passing argument 1 of âeap_detachâ discards qualifiers
from pointer target type
rlm_eap.c:115: warning: passing argument 1 of âeap_detachâ discards qualifiers
from pointer target type
rlm_eap.c:125: error: âstruct CONF_PARSERâ has no member named âtypesâ
rlm_eap.c:125: error: invalid operands to binary ==
rlm_eap.c:134: error: âstruct CONF_PARSERâ has no member named âtypesâ
rlm_eap.c:135: warning: passing argument 1 of âeap_detachâ discards qualifiers
from pointer target type
rlm_eap.c:144: warning: passing argument 1 of âeap_detachâ discards qualifiers
from pointer target type
rlm_eap.c:151: error: âstruct CONF_PARSERâ has no member named
âdefault_eap_type_nameâ
rlm_eap.c:151: warning: passing argument 1 of âeaptype_name2typeâ from
incompatible pointer type
rlm_eap.c:154: error: âstruct CONF_PARSERâ has no member named
âdefault_eap_type_nameâ
rlm_eap.c:154: warning: format â%sâ expects type âchar *â, but argument 3 has
type âconst struct CONF_PARSER *â
rlm_eap.c:155: warning: passing argument 1 of âeap_detachâ discards qualifiers
from pointer target type
rlm_eap.c:159: error: âstruct CONF_PARSERâ has no member named âtypesâ
rlm_eap.c:159: error: invalid operands to binary ==
rlm_eap.c:161: error: âstruct CONF_PARSERâ has no member named
âdefault_eap_type_nameâ
rlm_eap.c:161: warning: format â%sâ expects type âchar *â, but argument 3 has
type âconst struct CONF_PARSER *â
rlm_eap.c:162: warning: passing argument 1 of âeap_detachâ discards qualifiers
from pointer target type
rlm_eap.c:165: error: âstruct CONF_PARSERâ has no member named âdefault_eap_typeâ
rlm_eap.c:165: warning: statement with no effect
rlm_eap.c:176: error: âstruct CONF_PARSERâ has no member named âsession_mutexâ
rlm_eap.c:176: warning: passing argument 1 of âpthread_mutex_initâ from
incompatible pointer type
rlm_eap.c:177: error: âstruct CONF_PARSERâ has no member named âmodule_mutexâ
rlm_eap.c:177: warning: passing argument 1 of âpthread_mutex_initâ from
incompatible pointer type
rlm_eap.c:180: warning: statement with no effect
rlm_eap.c: In function âeap_authenticateâ:
rlm_eap.c:199: error: âinstâ undeclared (first use in this function)
rlm_eap.c:199: error: invalid operands to binary *
rlm_eap.c:199: warning: statement with no effect
rlm_eap.c:207: error: syntax error before â)â token
rlm_eap.c:262: error: âstruct CONF_PARSERâ has no member named âmodule_mutexâ
rlm_eap.c:262: warning: passing argument 1 of âpthread_mutex_lockâ from
incompatible pointer type
rlm_eap.c:274: error: âstruct CONF_PARSERâ has no member named âmodule_mutexâ
rlm_eap.c:274: warning: passing argument 1 of âpthread_mutex_unlockâ from
incompatible pointer type
rlm_eap.c:299: warning: passing argument 2 of ârequest_data_addâ discards
qualifiers from pointer target type
rlm_eap.c:322: warning: passing argument 2 of ârequest_data_addâ discards
qualifiers from pointer target type
rlm_eap.c:402: warning: pointer targets in passing argument 2 of âpairmakeâ
differ in signedness
rlm_eap.c:411: error: âstruct CONF_PARSERâ has no member named
âcisco_accounting_username_bugârlm_eap.c: In function âeap_authorizeâ:
rlm_eap.c:428: error: âinstâ undeclared (first use in this function)
rlm_eap.c:428: error: invalid operands to binary *
rlm_eap.c:428: warning: statement with no effect
rlm_eap.c:432: error: syntax error before â)â token
rlm_eap.c: In function âeap_post_proxyâ:
rlm_eap.c:560: warning: pointer targets in passing argument 2 of âpairmakeâ
differ in signedness
rlm_eap.c:593: warning: pointer targets in passing argument 1 of âstrncasecmpâ
differ in signedness
rlm_eap.c:618: warning: pointer targets in passing argument 4 of
ârad_tunnel_pwdecodeâ differ in signedness
rlm_eap.c:629: warning: pointer targets in passing argument 1 of
ârad_tunnel_pwencodeâ differ in signedness
rlm_eap.c:629: warning: pointer targets in passing argument 4 of
ârad_tunnel_pwencodeâ differ in signedness
gmake[6]: *** [rlm_eap.o] Error 1
gmake[6]: Leaving directory
`/usr/src/redhat/BUILD/freeradius-1.0.2/src/modules/rlm_eap'
gmake[5]: *** [common] Error 1
gmake[5]: Leaving directory `/usr/src/redhat/BUILD/freeradius-1.0.2/src/modules'
gmake[4]: *** [all] Error 2
gmake[4]: Leaving directory `/usr/src/redhat/BUILD/freeradius-1.0.2/src/modules'
gmake[3]: *** [common] Error 1
gmake[3]: Leaving directory `/usr/src/redhat/BUILD/freeradius-1.0.2/src'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/usr/src/redhat/BUILD/freeradius-1.0.2/src'
gmake[1]: *** [common] Error 1
gmake[1]: Leaving directory `/usr/src/redhat/BUILD/freeradius-1.0.2'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.78631 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.78631 (%build)
----------------------------------

This also happens when we try to compile from sources and trying to compile a
.src.rpm known to compile perfectly on FC3. Even, the .src.rpm from the Fedora
Core 4 SRPMS tree compiles nicelly on an FC3. This makes me think that the
.src.rpm does not correspond to the .i386.rpm on the sources tree.

Comment 3 Thomas Woerner 2005-07-19 13:00:33 UTC
*** Bug 163072 has been marked as a duplicate of this bug. ***

Comment 4 Gerwin Krist 2005-07-31 13:36:13 UTC
It's included in the 1.0.4 version.


Note You need to log in before you can comment on or make changes to this bug.