Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160864 - On machines with no sound HW, gnome-volume-control should silently fail
Summary: On machines with no sound HW, gnome-volume-control should silently fail
Keywords:
Status: CLOSED DUPLICATE of bug 160395
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-media
Version: 4
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 20:57 UTC by John William
Modified: 2013-03-13 04:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-13 04:20:58 UTC


Attachments (Terms of Use)

Description John William 2005-06-17 20:57:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
On machines with no sound hardware, the default FC4 installation has a volume control that starts with the desktop startup. Every time a user logs in, they get a "No volume control elements and/or devices found." which they have to acknowledge (ok, I guess they don't *have* to, but it does get confusing/annoying).

At logout time, when X is shutting down, there is another box that flashes by too quickly to see, but I assume it's from the applet trying to save the mixer settings.

Version-Release number of selected component (if applicable):
gnome-media-2.10.2-4

How reproducible:
Always

Steps to Reproduce:
1. Install and start FC4 on a machine with no sound HW.
2. Get annoyed by the dialog boxes at login and logout time.
3.
  

Actual Results:  Annoying dialog box appears.

Expected Results:  If there is no sound hardware present, it should silently fail. If there is a problem with a machine where sound hardware is present, but not working, then the user will probably go to the sound card detection applet.

Additional info:

Comment 1 Matthias Clasen 2005-10-13 04:20:58 UTC

*** This bug has been marked as a duplicate of 160395 ***


Note You need to log in before you can comment on or make changes to this bug.