Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160831 - isdn fails to load at system startup
Summary: isdn fails to load at system startup
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: isdn4k-utils
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 18:26 UTC by Tomasz Kepczynski
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-20 21:43:26 UTC


Attachments (Terms of Use)

Description Tomasz Kepczynski 2005-06-17 18:26:17 UTC
Description of problem:
When system boots up /etc/init.d/isdn start reports failure.
This is probably due to workaround from other bug (133889),
which resulted in makedev subroutine being introduced to create
isdn device nodes on udev introduction. The problem seems to be related
to fact that hisax and other isdn modules seem to be loaded in kernel at
the point when isdn startup script is executed. This results in two
problems:
1. module cannot be loaded with parameters specified in
   /etc/sysconfig/isdncard
2. It looks like device nodes created in /dev if created AFTER module
   is loaded don't work
I am not sure but the problem is very likely related to udev. As I
understand udev tries very early during boot process to discover connected
hardware which would explain presence of isdn modules in single user mode
(i.e. before isdn script is executed). Unfortunately isdn and udev don't
seem to play nice with each other and udev does not create isdn device nodes.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
This is not the same as during boot but it may show you a point.
1. unload all isdm modules and remove all isdn device nodes from /dev
2. modprobe hisax (or whatever card you have, I don't know the behaviour
   with other hardware modules)
3. service isdn start -> it fails due to isdnctrl failing in line 121
4. service isdn start -> now it works as device nodes in /dev already
   exist and module was unloaded in step 3 as part of script cleanup
  
Actual results:
isdn does not load during boot

Expected results:
isdn loads during boot

Additional info:
I don't really know if the bug should be filed for isdn4k-utils, kernel
or udev. Please reassign as needed.
And it is high time to have it properly fixed, as workarounds are mess.

Comment 1 Ngo Than 2005-06-20 21:43:26 UTC
it's now fixed in isdn4k-utils-3_2-29, which will be available in rawhide soon.
Could you verify it please. Thanks

Comment 2 Ngo Than 2005-06-20 21:43:53 UTC
it's now fixed in isdn4k-utils-3_2-29, which will be available in rawhide soon.
Could you verify it please. Thanks


Note You need to log in before you can comment on or make changes to this bug.