Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160828 - Non-GPG key confuses up2date and yum
Summary: Non-GPG key confuses up2date and yum
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: evince
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marco Pesenti Gritti
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 18:01 UTC by Michael Tiemann
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-29 21:25:18 UTC


Attachments (Terms of Use)

Description Michael Tiemann 2005-06-17 18:01:58 UTC
Description of problem:

The evince package is not signed with a GPG key.  up2date simply aborts because
there is no such key, and yum flags it and asks whether to proceed or not.

Version-Release number of selected component (if applicable):

evince-0.3.1-1.i386.rpm

How reproducible:

On an fc4 system that does not have evince installed, try to use up2date

Steps to Reproduce:
1. rpm -e evince
2. up2date evince

Actual results:

evince-0.3.1-1.i386.rpm:    ########################## Done.
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID
4f2a6fd2
The package evince-0.3.1-1 is not signed with a GPG signature.
Aborting...
Package evince-0.3.1-1 does not have a GPG signature.
 Aborting...

Expected results:


Additional info:


Note You need to log in before you can comment on or make changes to this bug.