Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160827 - redhat-config-printer crashed after detecting numeric printer queue name
Summary: redhat-config-printer crashed after detecting numeric printer queue name
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: redhat-config-printer
Version: 4.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 17:56 UTC by George Liu
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-20 10:07:52 UTC


Attachments (Terms of Use)

Description George Liu 2005-06-17 17:56:41 UTC
Description of problem: 
Used CUPS web GUI to create a printer queue named 2232.  
Start redhat-config-printer, and redhat-config-printer will crash.  
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
 
 
Steps to Reproduce: 
1.Use cups webgui to create a printer named 2232  
2.start redhat-config-printer  
3.redhat-config-printer will crash.  
   
Actual results: 
 
 
Expected results: 
 
 
Additional info:

Comment 1 Tim Waugh 2005-06-20 10:00:11 UTC
FWIW, the code that imports CUPS-created queues into the redhat-config-printer
configuration database has been removed since Red Hat Enterprise Linux 4, so
future releases should not be affected.


Comment 2 Tim Waugh 2005-06-20 10:07:52 UTC
You cannot in general create a queue in CUPS and be able to edit it correctly
using redhat-config-printer.  It is better, if you intend to use
redhat-config-printer, to create the queue there in the first instance. 
Alternatively, you can use the CUPS web interface exclusively.

Since this work-around is available, I am closing this bug as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.