Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160821 - evolution-alarm-notify crashes
Summary: evolution-alarm-notify crashes
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 15:58 UTC by Andrew Overholt
Modified: 2008-08-02 23:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-02 17:03:05 UTC


Attachments (Terms of Use)

Description Andrew Overholt 2005-06-17 15:58:34 UTC
Description of problem:
evolution-alarm-notify crashes.

Version-Release number of selected component (if applicable):
evolution-2.2.2-7

How reproducible:
Not 100% but fairly often.

Steps to Reproduce:
1. start evolution
2.
3.
  
Actual results:
Error dialog from evolution-alarm-notify crash.

Expected results:
No dialog :)

Additional info: (taken from bug-buddy ... sorry I didn't have the debuginfo
installed)

Backtrace was generated from '/usr/libexec/evolution-alarm-notify'

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -135536608 (LWP 12652)]
[New Thread -138201888 (LWP 12653)]
0x0f81e7e0 in __waitpid_nocancel () from /lib/libpthread.so.0
#0  0x0f81e7e0 in __waitpid_nocancel () from /lib/libpthread.so.0
#1  0x0f40bc98 in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
#2  <signal handler called>
#3  0x0fea306c in raise () from /lib/libc.so.6
#4  0x0fea4b70 in abort () from /lib/libc.so.6
#5  0x0fbfc554 in g_logv () from /usr/lib/libglib-2.0.so.0
#6  0x0fbfc5cc in g_log () from /usr/lib/libglib-2.0.so.0
#7  0x0fbfc670 in g_assert_warning () from /usr/lib/libglib-2.0.so.0
#8  0x10010ff0 in alarm_trigger_cb (alarm_id=0x1009e0f0, trigger=1114092900, 
    data=) at alarm-queue.c:325
#9  0x28004422 in ?? ()
#10 0x1000dce8 in alarm_ready_cb (data=) at alarm.c:99
#11 0x0fbf30c4 in g_main_context_wakeup () from /usr/lib/libglib-2.0.so.0
#12 0x0fbf08d4 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#13 0x0fbf4bac in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#14 0x0fbf5004 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#15 0x0ecf6414 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#16 0x0fbf30c4 in g_main_context_wakeup () from /usr/lib/libglib-2.0.so.0
#17 0x0fe8b8cc in generic_start_main () from /lib/libc.so.6
#18 0x0fe8ba64 in __libc_start_main () from /lib/libc.so.6
#19 0x0fe8ba64 in __libc_start_main () from /lib/libc.so.6

Thread 2 (Thread -138201888 (LWP 12653)):
#0  0x0ff43e6c in poll () from /lib/libc.so.6
No symbol table info available.
#1  0x0fbf4a48 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#2  0x0fbf5004 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x0eb86aa4 in link_thread_io_context () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#4  0x0fc157f0 in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#5  0x0f815878 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#6  0x0ff43e54 in poll () from /lib/libc.so.6
No symbol table info available.
#7  0x00000000 in ?? ()
No symbol table info available.

Thread 1 (Thread -135536608 (LWP 12652)):
#0  0x0f81e7e0 in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#1  0x0f40bc98 in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#2  <signal handler called>
No symbol table info available.
#3  0x0fea306c in raise () from /lib/libc.so.6
No symbol table info available.
#4  0x0fea4b70 in abort () from /lib/libc.so.6
No symbol table info available.
#5  0x0fbfc554 in g_logv () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x0fbfc5cc in g_log () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#7  0x0fbfc670 in g_assert_warning () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#8  0x10010ff0 in alarm_trigger_cb (alarm_id=0x1009e0f0, trigger=1114092900, 
    data=) at alarm-queue.c:325
	cqa = (CompQueuedAlarms *) 0x100bd4b0
	comp =

Comment 1 Andrew Overholt 2005-06-17 16:02:09 UTC
Actually, I did have debuginfo installed at this point.

Comment 2 Dave Malcolm 2005-06-29 16:31:46 UTC
Possibly a dup of gnome bug 274406, though I can't check ATM since gnome
bugzilla is down; this was fixed in evolution 2.2.3, so I'll push an update out
in any case.

Comment 3 Dave Malcolm 2005-06-30 03:48:25 UTC
Please try the 2.2.3 test FC4 package

Comment 4 Dave Malcolm 2005-11-10 15:22:31 UTC
I'm seeing this at the moment (intermittently, possible only when alarms fire?)

evolution-2.4.1-8
evolution-data-server-1.4.1.1-1
evolution-connector-2.4.1-1
(not all of these have reached rawhide yet IIRC)

Backtrace was generated from '/usr/libexec/evolution-alarm-notify'

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208523088 (LWP 5147)]
[New Thread -1211016272 (LWP 5148)]
0x00b91402 in ?? ()
#0  0x00b91402 in ?? ()
#1  0x00c8807b in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x027d34dd in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x00b91402 in ?? ()
#5  0x00a607e8 in raise () from /lib/libc.so.6
#6  0x00a61f58 in abort () from /lib/libc.so.6
#7  0x00ccfe98 in IA__g_logv (log_domain=) at gmessages.c:497
#8  0x00ccfece in IA__g_log (log_domain=0x805b24d "evolution-alarm-notify", 
    log_level=G_LOG_LEVEL_ERROR, 
    format=0xcf68a0 "file %s: line %d (%s): should not be reached")
    at gmessages.c:517
#9  0x00ccff3a in IA__g_assert_warning (
    log_domain=0x805b24d "evolution-alarm-notify", 
    file=0x805b79f "alarm-queue.c", line=333, 
    pretty_function=0x805bf24 "alarm_trigger_cb", expression=0x0)
    at gmessages.c:552
#10 0x08057e55 in alarm_trigger_cb (alarm_id=0x8460ed8, trigger=1131632100, 
    data=0x8468470) at alarm-queue.c:1150
#11 0x08054c19 in alarm_ready_cb (data=0x0) at alarm.c:99
#12 0x00cc8566 in g_timeout_dispatch (source=0x845ed00, 
    callback=0x8054b5d <alarm_ready_cb>, user_data=0x0) at gmain.c:3293
#13 0x00cc6a50 in IA__g_main_context_dispatch (context=0x83e7fe0)
    at gmain.c:1934
#14 0x00cc9a66 in g_main_context_iterate (context=0x83e7fe0, block=1, 
    dispatch=1, self=0x83cfe50) at gmain.c:2565
#15 0x00cc9d53 in IA__g_main_loop_run (loop=0x8423980) at gmain.c:2769
#16 0x0034d600 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#17 0x080599f6 in main (argc=3, argv=0xbfca0b94) at notify-main.c:169
#18 0x00a4d50f in __libc_start_main () from /lib/libc.so.6
#19 0x0804ffe1 in _start ()

Thread 2 (Thread -1211016272 (LWP 5148)):
#0  0x00b91402 in ?? ()
No symbol table info available.
#1  0x00af9560 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x00cc98b8 in g_main_context_iterate (context=0x8436360, block=1, 
    dispatch=1, self=0x83f36c8) at gmain.c:2867
	max_priority = 2147483647
	timeout = -1
	some_ready = 
Thread 1 (Thread -1208523088 (LWP 5147)):
#0  0x00b91402 in ?? ()
No symbol table info available.
#1  0x00c8807b in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x027d34dd in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x00b91402 in ?? ()
No symbol table info available.
#5  0x00a607e8 in raise () from /lib/libc.so.6
No symbol table info available.
#6  0x00a61f58 in abort () from /lib/libc.so.6
No symbol table info available.
#7  0x00ccfe98 in IA__g_logv (log_domain=) at gmessages.c:497
	depth = 1
	domain = (GLogDomain *) 0x0
	data = 0x0
	log_func = 0xcd04d3 <IA__g_log_default_handler>
	domain_fatal_mask = 5
	test_level = 6
	was_fatal = 0
	was_recursion = 0
	i = 

Comment 5 Dave Malcolm 2005-11-10 15:24:25 UTC
Yes, both backtraces are assertions failing when alarm_trigger_cb fires

Comment 7 Matthew Barnes 2006-12-31 17:25:29 UTC
Does the reported problem still occur in Fedora Core 6?

Comment 8 Andrew Overholt 2007-01-02 17:03:05 UTC
I don't see it anymore.  Closing.


Note You need to log in before you can comment on or make changes to this bug.