Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160819 - Missing header files in kernel-devel package
Summary: Missing header files in kernel-devel package
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL: https://www.redhat.com/archives/fedor...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 15:42 UTC by Dawid Gajownik
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-07 23:33:51 UTC


Attachments (Terms of Use)

Description Dawid Gajownik 2005-06-17 15:42:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b) Gecko/20050217

Description of problem:
I'm not able to compile lirc kernel module, because some header files are missing.

Version-Release number of selected component (if applicable):
kernel-devel-2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
Please visit this URL → https://www.redhat.com/archives/fedora-devel-list/2005-March/msg01582.html

Additional info:

https://www.redhat.com/archives/fedora-devel-list/2005-March/msg01611.html

Comment 1 Dave Jones 2005-07-07 23:33:51 UTC
The problem is due to bttv.h living outside of include/
If this is intended to be used by non-bttv modules, upstream should move it to
include/

We can't feasibly do this in Fedora, as the kernel changes so frequently that
every time a change was made to those .h files, we'd have to regenerate diffs.



Note You need to log in before you can comment on or make changes to this bug.