Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160814 - Compiling emacs fails with segfault related to exec-shield
Summary: Compiling emacs fails with segfault related to exec-shield
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 14:26 UTC by B. O'Falon
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-22 01:37:13 UTC


Attachments (Terms of Use)

Description B. O'Falon 2005-06-17 14:26:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511

Description of problem:
When attempting to compile emacs versions 21.3.50 or 22.0.50, the compile process fails with the below messages:

Dumping under names emacs and emacs-21.3.50
**************************************************
Warning: Your system has a gap between BSS and the
heap (19112100 byte).  This usually means that exec-shield
or something similar is in effect.  The dump may
fail because of this.  See the section about
exec-shield in etc/PROBLEMS for more information.
**************************************************
make[1]: *** [bootstrap-emacs] Segmentation fault
make[1]: Leaving directory `/home/bof/downloads/emacs/emacs/src'
make: *** [bootstrap-build] Error 2

Version-Release number of selected component (if applicable):
emacs 22.0.50 and emacs 21.3.50

How reproducible:
Always

Steps to Reproduce:
1. attempt to compile emacs 22.0.50 from CVS download or emacs 21.3.50 from source file "emacs-21.3.50-20041117.tar.gz" available at  
http://sourceforge.net/project/showfiles.php?group_id=17203&package_id=35022&release_id=78364

2. issue "setarch i386 ./configure"

3. issue "setarch i386 make bootstrap"
  
4. watch error messages appear and compile fail

5. gnash teeth

Actual Results:  compiling during the "setarch i386 make bootstrap" failed with error message

Expected Results:  the compilation should have finished and I could then issue "make install" to finish the process

Additional info:

The compilation was done with the following commands (which worked with FC3)

setarch i386 ./configure
setarch i386 make bootstrap

I also tried using "setarch i386 make" instead of "setarch i386 make bootstrap" and also tried before compiling issuing "echo 0 > /proc/sys/kernel/exec-shield' to turn off exec-shield completely

None of these worked: the compilation still failed with the following messages

<snip>
Loading menu-bar (source)...
Loading paths.el (source)...
Loading startup (source)...
Loading emacs-lisp/lisp (source)...
Loading textmodes/page (source)...
Loading register (source)...
Loading textmodes/paragraphs (source)...
Loading emacs-lisp/lisp-mode (source)...
Loading textmodes/text-mode (source)...
Loading textmodes/fill (source)...
((215107 . 8234) (11326 . 3) (584 . 196) 1542561 223532 (66 . 7) (18 . 43) (23593 . 599))
Loading replace (source)...
Loading abbrev (source)...
Loading buff-menu (source)...
Loading emacs-lisp/float-sup (source)...
((222553 . 3029) (11533 . 2) (585 . 195) 1575995 223956 (72 . 4) (18 . 43) (24103 . 215))
Loading vc-hooks (source)...
Loading ediff-hook (source)...
((225572 . 2596) (11635 . 0) (586 . 194) 1584303 223973 (72 . 4) (18 . 43) (24359 . 337))
Finding pointers to doc strings...
Finding pointers to doc strings...done
Dumping under names emacs and emacs-21.3.50
**************************************************
Warning: Your system has a gap between BSS and the
heap (19112100 byte).  This usually means that exec-shield
or something similar is in effect.  The dump may
fail because of this.  See the section about
exec-shield in etc/PROBLEMS for more information.
**************************************************
make[1]: *** [bootstrap-emacs] Segmentation fault
make[1]: Leaving directory `/home/bof/downloads/emacs/emacs/src'
make: *** [bootstrap-build] Error 2

Comment 1 Jens Petersen 2005-07-14 13:19:42 UTC
This was fixed recently in emacs cvs.

A backport of that patch is in emacs-21.4-7, which should be
in FC development soon.


Note You need to log in before you can comment on or make changes to this bug.