Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160807 - Internal compiler error building dialog.c in WINE CVS
Summary: Internal compiler error building dialog.c in WINE CVS
Keywords:
Status: CLOSED DUPLICATE of bug 160026
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 13:27 UTC by Tim Smith
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-17 13:29:08 UTC


Attachments (Terms of Use)
Preprocessed source from compiler (deleted)
2005-06-17 13:29 UTC, Tim Smith
no flags Details

Description Tim Smith 2005-06-17 13:27:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.0 (like Gecko)

Description of problem:
make[2]: Entering directory `/local/tim/build/wine/dlls/msi'  
gcc -m32 -c -I. -I. -I../../include -I../../include  -D__WINESRC__    
-D_REENTRANT -fPIC -Wall -pipe -mpreferred-stack-boundary=2  
-fno-strict-aliasing -gstabs+ -Wpointer-arith  -g -O2 -o dialog.o dialog.c  
dialog.c: In function âmsi_dialog_scrolltext_controlâ:  
dialog.c:517: internal compiler error: in gimple_add_tmp_var, at  
gimplify.c:532  
Please submit a full bug report,  
with preprocessed source if appropriate.  
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.  
 
Will attach preprocessed source in a minute 

Version-Release number of selected component (if applicable):
gcc-4.0.0-11

How reproducible:
Always

Steps to Reproduce:
1. Check out WINE CVS 
2. Configure with CC='gcc -m32' ./configure --x-libraries=/usr/X11R6/lib 
3. make 
   

Actual Results:  See description  

Additional info:

Comment 1 Jakub Jelinek 2005-06-17 13:29:08 UTC

*** This bug has been marked as a duplicate of 160026 ***

Comment 2 Tim Smith 2005-06-17 13:29:26 UTC
Created attachment 115608 [details]
Preprocessed source from compiler


Note You need to log in before you can comment on or make changes to this bug.