Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160806 - cannot use alternate installed languages as default system language
Summary: cannot use alternate installed languages as default system language
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 13:17 UTC by Dimitri Papadopoulos
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-29 14:39:22 UTC


Attachments (Terms of Use)
screenshot of system-config-language (deleted)
2005-06-17 13:17 UTC, Dimitri Papadopoulos
no flags Details

Description Dimitri Papadopoulos 2005-06-17 13:17:58 UTC
Description of problem:
I've followed the instructions in the "Fedora Core 4 Installation Guide":
http://fedora.redhat.com/docs/fedora-install-guide-en/fc4/

1. I'm installing FC4 from CDs, this is really a vanilla installation.
2. In the "Language Selection" form (paragraph 3.1 of the guide) I choose
English - I prefer using that language during installation.
3. I need to install support for additional languages. Actually I would like
French to be the default language for the system aftar installation. I follow
the instructions in paragraph 12.3 of the guide and select French, Greek,
German, Spanish, Italian, Chinese, Korean, Japanese as additional languages.
4. After rebooting, only English (en_US) can be used as the default system language:
	# cat /etc/sysconfig/i18n
	LANG="en_US.UTF-8"
	SYSFONT="latarcyrheb-sun16"
	SUPPORTED="en_US.UTF-8:en_US:en"
	# 
English had been chosen as the *installation* language udring installation. Now
I would like French (fr_FR) to be the *default system language* but
system-config-language does offer any choice. See attached screenshot.

At first sight this may look as a duplicate of #160800 but it's not, although
it's related. The problem here is that alternate languages are actually *not*
completely installed. This is not about how involved it is to install them.

Version-Release number of selected component (if applicable):
anaconda-10.2.1.5-2

How reproducible:
Always

Comment 1 Dimitri Papadopoulos 2005-06-17 13:17:59 UTC
Created attachment 115607 [details]
screenshot of system-config-language

Comment 2 Dimitri Papadopoulos 2005-06-17 13:24:46 UTC
Actually it is a duplicate, I should have read bug #160800 more in detail.

Still, bug #160800 is about two distinct issues:
1) It's not easy to install additional languages.
2) Once these additional languages are installed, they cannot be used as the
system default language and system-config-language is actually useless.

The first issue is a usability issue.
The second issue is a real bug that requires hacking files in /etc/sysconfig to
work around.

*** This bug has been marked as a duplicate of 160800 ***

Comment 3 Dimitri Papadopoulos 2005-06-28 13:20:45 UTC
Since 160800 has been wrongly closed, I'm reopening this one.

Comment 4 Chris Lumens 2005-06-29 14:39:22 UTC
Fixed in Rawhide again.  We don't need to write out a SUPPORTED line in
/etc/sysconfig/i18n since there are cases we can't write it out correctly and
s-c-languages will do just fine without it.


Note You need to log in before you can comment on or make changes to this bug.