Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160788 - cpuspeed will not start on a Pentium-M alviso with 915GM/PM/GMS/910GML chipset
Summary: cpuspeed will not start on a Pentium-M alviso with 915GM/PM/GMS/910GML chipset
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cpuspeed
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Liang Zhang
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 10:03 UTC by Kjetil Nygård
Modified: 2015-04-07 03:06 UTC (History)
2 users (show)

Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-22 02:19:46 UTC


Attachments (Terms of Use)

Description Kjetil Nygård 2005-06-17 10:03:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When I run 
[root@kjetil kjetil]# /etc/init.d/cpuspeed restart
[root@kjetil kjetil]#

Nothing happens, and the deamon doesn't start.

When i run cpuspeed the following happens:
[root@kjetil kjetil]# cpuspeed
Error: Could not open file for writing: /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
Error: No such file or directory
[root@kjetil kjetil]#


I guess the problem is support for my chipset or cpu is not recognized.

Version-Release number of selected component (if applicable):
cpuspeed-1.2.1-1.21

How reproducible:
Always

Steps to Reproduce:
1.cpuspeed
2.
3.
  

Actual Results:  When i run cpuspeed the following happens:
[root@kjetil kjetil]# cpuspeed
Error: Could not open file for writing: /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
Error: No such file or directory

Expected Results:  That cpuspeed is running.

Additional info:

The output of /proc/cpuinfo is:
[root@kjetil kjetil]# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 1.73GHz
stepping        : 8
cpu MHz         : 1729.275
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe est tm2
bogomips        : 3416.06

Which i guess says that it doesn't know a whole lot about the CPU.

Comment 1 Kjetil Nygård 2005-06-22 20:37:45 UTC
The problem is that the kernel doesn't load the right module: acpi_cpufreq
When this module is loaded, it starts CPU-speed automaticly.

Comment 2 Dave Jones 2005-09-24 00:08:40 UTC
will be fixed in cpuspeed-1.2.1-1.23_FC4 which should go to updates-testing real
soon.


Comment 3 Damian Menscher 2005-10-09 18:22:13 UTC
Seeing the same problem on RHEL4, but that doesn't have a cpuspeed rpm (cpuspeed
is part of kernel-utils).  Suggestions appreciated.

Comment 4 Bill Nottingham 2006-09-22 02:19:46 UTC
Closing bugs in MODIFIED state from prior Fedora releases. If this bug persists
in a current Fedora release (such as Fedora Core 5 or later), please reopen and
set the version appropriately.


Note You need to log in before you can comment on or make changes to this bug.