Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160787 - no user entry in /etc/passwd after useradd
Summary: no user entry in /etc/passwd after useradd
Alias: None
Product: Fedora
Classification: Fedora
Component: shadow-utils
Version: 4
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: David Lawrence
Depends On:
TreeView+ depends on / blocked
Reported: 2005-06-17 09:52 UTC by Daniel Hammer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-06-29 10:58:21 UTC

Attachments (Terms of Use)

Description Daniel Hammer 2005-06-17 09:52:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
If a user is added via "useradd foo" a directory is created but there is no new entry line in /etc/passwd. Consequently "passwd foo" will fail with the error message that user foo does not exist.
The gui tool system-config-users does create the users correctly and passwords are  also given correctly.
Tried to switch off selinux, first to permissive and the to disabled but this does not change anything.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. login as root
2. type useradd foo and then passwd foo

Actual Results:  1. get an error message that user foo does not exist 
2. see that /home/foo was nevertheless created

Expected Results:  the user should be created correctly.

Additional info:

Comment 1 Peter Vrabec 2005-06-28 10:07:18 UTC
I can't reproduce it.

# useradd foo
# cat /etc/passwd | grep foo
# rpm -q shadow-utils

Comment 2 Daniel Hammer 2005-06-28 17:28:19 UTC
Ok, now it works for me too, but I have installed a whole bunch of updates now.
On a fresh install it didn't work.

Note You need to log in before you can comment on or make changes to this bug.