Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160777 - Matrox G550 driver problems
Summary: Matrox G550 driver problems
Keywords:
Status: CLOSED DUPLICATE of bug 161242
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 09:04 UTC by Florian Knell
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-23 21:19:48 UTC


Attachments (Terms of Use)

Description Florian Knell 2005-06-17 09:04:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
The Installer is not able to display an correct screen after probing the hardware.
If i use DVI-input the monitor screen turns to black and the osd said i should check the frequencies, cause they are out of range.
I could reproduce the problem with an 19" CRT and the LCD form above with analog input. But in this case the screen turn not into black and i see interferences like white vertical bars, some flick flack and so one...

I installed the system in text mode and tried to configure the X-server manually later. After a few hours i gave up with the same results which i descripted above.

If necessary i would post logfiles or xorg.conf.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Running Installer from CD with Matrox G550 graphics adapter or try to run xserver after installing the system in text mode.

Additional info:

Matrox G550 dvi and analog output
Iiyama ProLite 431s TFT with dvi and analog in
Videseven 19" CRT monitor

Comment 1 Mike A. Harris 2005-06-17 16:45:08 UTC
The "mga" driver does not support DVI officially.  It contains only
experimental code which Matrox never completed into a stable workable
state.

After using analog cable instead, please reproduce the problem and
attach your X server log and config file using the link below.  There
are numerous problems with mga support currently, so this is likely
a duplicate.  Once we have your details, we can determine if it is
the same issue already reported, or a new issue.

TIA

Comment 2 Florian Knell 2005-06-17 21:02:04 UTC
I tried at first the analog output, because i had that dvi problems with every
linux distribution i installed. The difference between them and the fc4
installer was analog works fine and dvi works after installing the mga-driver
from Matrox. 

Frusted of my results i recoverd the old installation. I could run the installer
and could attach the X server log, but not before tomorow. Hope thats okay.

Comment 3 Florian Knell 2005-06-17 21:02:39 UTC
I tried at first the analog output, because i had that dvi problems with every
linux distribution i installed. The difference between them and the fc4
installer was analog works fine and dvi works after installing the mga-driver
from Matrox. 

Frusted of my results i recovered the old installation. I could run the
installer and could attach the X server log, but not before tomorow. Hope thats
okay.

Comment 4 Florian Knell 2005-06-22 20:49:27 UTC
I'm not able to copy the X server log. After starting the X Server the complete
commandline output turned to character salad. This happend on every terminal.

I made some bad screenshots with my mobile cam, if it's hopefull i will attach them.

Comment 5 Mike A. Harris 2005-06-23 19:13:25 UTC
This problem is believed to possibly be a duplicate of libvgahw.  Please
read bug #161242 and test the libvgahw.a module that is available at
the following URL:

    ftp://people.redhat.com/mharris/libvgahw.a

Make a backup copy of the original libvgahw.a module prior to replacing it
with the one from above.  Once you've replaced it, restart the X server or
reboot the system.  After doing this, please indicate if there is any change
in the problem.  You may wish to CC yourself on bug #161242 as well, assuming
this does turn out to be a duplicate.

Also, please attach your X server log from /var/log and your X server config
file /etc/X11/xorg.conf to all X related bug reports, as this makes it
easier for developers to perform a diagnosis.  You can get the logs by
setting "initdefault" to 3 in /etc/inittab and running "init 3", then
using "startx" to start the X server.  If the machine crashes or display
is corrupted, reboot, and backup the logs after rebooting *before*
starting X again.  Attach those to the report.


Thanks in advance.

Comment 6 Florian Knell 2005-06-23 21:19:48 UTC
It's definitively an dublicate of bug #161242.

During the start up of the installer imho it is not possible to replace the
libvgahw and there is also no way to get an copy of the x server log and config.

I recoverd my old OS because i need my box for daily working. 




*** This bug has been marked as a duplicate of 161242 ***

Comment 7 Mike A. Harris 2005-06-23 21:30:49 UTC
Thanks for the update!


Note You need to log in before you can comment on or make changes to this bug.