Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160774 - pcspkr module still not loaded at boot time
Summary: pcspkr module still not loaded at boot time
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
: 162361 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 08:01 UTC by Andre Robatino
Modified: 2014-03-17 02:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-07 18:19:57 UTC


Attachments (Terms of Use)

Description Andre Robatino 2005-06-17 08:01:14 UTC
Description of problem:
  The pcspkr module is still not loaded at boot time.  I had to create an
executable file /etc/rc.modules with "/sbin/modprobe pcspkr" in it to make this
happen, as in FC3.

Version-Release number of selected component (if applicable):
initscripts-8.11.1-1

How reproducible:
always

Steps to Reproduce:
1.  Boot into FC4.
  
Actual results:
Note that the PC speaker doesn't work (no beep at login, etc.).

Expected results:
PC speaker should work.

Additional info:
Clean install of FC4.

Comment 1 Daniel Roesen 2005-07-03 17:41:30 UTC
*** Bug 162361 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 2005-10-03 21:21:36 UTC
The long-term fix for this is to get it loaded based on some intrinsic kernel
property, that can be probed and plugged through the normal hotplug mechanisms.

The short-term fix is a workaround in /etc/rc.modules.

Comment 3 Dan Williams 2006-06-29 14:51:13 UTC
Note that this seems to be loaded and installed now in Rawhide, specifically
2.6.17-1.2328.fc6.  So damn annoying.

Comment 4 Matt Seitz 2006-06-29 15:07:28 UTC
I'm pleased to read this is being fixed soon.  Thank you for fixing this.

Comment 5 Bill Nottingham 2006-08-07 18:19:57 UTC
This is fixed in the current FC6 devel tree.


Note You need to log in before you can comment on or make changes to this bug.