Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160770 - OOo crashes at startup due to version `GLIBC_2.3.3' not found, as required by libuno_sal.so.3
Summary: OOo crashes at startup due to version `GLIBC_2.3.3' not found, as required by...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 06:55 UTC by Stephen Sekula
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-22 04:26:30 UTC


Attachments (Terms of Use)

Description Stephen Sekula 2005-06-17 06:55:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Upon execution of ooffice (or any component of  OOo), the following error is printed to the screen:

/usr/lib/openoffice.org1.9.104/program/soffice.bin: /lib/obsolete/linuxthreads/libpthread.so.0: version `GLIBC_2.3.3' not found (required by /usr/lib/openoffice.org1.9.104/program/libuno_sal.so.3)



Version-Release number of selected component (if applicable):
openoffice.org-core-1.9.104-2

How reproducible:
Always

Steps to Reproduce:
1. execute "ooffice" (or oowriter, etc. -- anything that calls soffice.bin)

  

Actual Results:  OOo immediately crashes with the error in the summary.

Expected Results:  OOo should have started normally.

Additional info:

The glibc version installed on my system is glibc-2.3.5-10. This is a very fresh update from FC3 to FC4, and I noticed the problem immediately upon upgrade (and subsequent installation of all pending updates).

Running ldd on soffice.bin yields the following:

@papa ~> ldd /usr/lib/openoffice.org1.9.104/program/soffice.bin
/usr/lib/openoffice.org1.9.104/program/soffice.bin: /lib/obsolete/linuxthreads/libpthread.so.0: version `GLIBC_2.3.3' not found (required by /usr/lib/openoffice.org1.9.104/program/libuno_sal.so.3)
        linux-gate.so.1 =>  (0x4001c000)
        libvcl680li.so => /usr/lib/openoffice.org1.9.104/program/libvcl680li.so (0x4001e000)
        libsvl680li.so => /usr/lib/openoffice.org1.9.104/program/libsvl680li.so (0x40282000)
        libsvt680li.so => /usr/lib/openoffice.org1.9.104/program/libsvt680li.so (0x4032d000)
        libutl680li.so => /usr/lib/openoffice.org1.9.104/program/libutl680li.so (0x40628000)
        libtl680li.so => /usr/lib/openoffice.org1.9.104/program/libtl680li.so (0x40691000)
        libcomphelp4gcc3.so => /usr/lib/openoffice.org1.9.104/program/libcomphelp4gcc3.so (0x40725000)
        libucbhelper3gcc3.so => /usr/lib/openoffice.org1.9.104/program/libucbhelper3gcc3.so (0x407e0000)
        libvos3gcc3.so => /usr/lib/openoffice.org1.9.104/program/libvos3gcc3.so (0x40840000)
        libuno_cppuhelpergcc3.so.3 => /usr/lib/openoffice.org1.9.104/program/libuno_cppuhelpergcc3.so.3 (0x4085d000)
        libuno_cppu.so.3 => /usr/lib/openoffice.org1.9.104/program/libuno_cppu.so.3 (0x408a0000)
        libuno_sal.so.3 => /usr/lib/openoffice.org1.9.104/program/libuno_sal.so.3 (0x408cd000)
        libtk680li.so => /usr/lib/openoffice.org1.9.104/program/libtk680li.so (0x40a7e000)
        libjvmfwk.so.3 => /usr/lib/openoffice.org1.9.104/program/libjvmfwk.so.3 (0x40c26000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40c5b000)
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x40c6a000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x40c73000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40c8e000)
        libdl.so.2 => /lib/libdl.so.2 (0x40d62000)
        libpthread.so.0 => /lib/obsolete/linuxthreads/libpthread.so.0 (0x40d66000)
        libstlport_gcc.so => /usr/lib/openoffice.org1.9.104/program/libstlport_gcc.so (0x40db9000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x40e79000)
        libm.so.6 => /lib/obsolete/linuxthreads/libm.so.6 (0x40f5f000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x40f84000)
        libc.so.6 => /lib/obsolete/linuxthreads/libc.so.6 (0x40f8e000)
        libsot680li.so => /usr/lib/openoffice.org1.9.104/program/libsot680li.so (0x410bb000)
        libicuuc.so.26 => /usr/lib/openoffice.org1.9.104/program/libicuuc.so.26 (0x41103000)
        libicule.so.26 => /usr/lib/openoffice.org1.9.104/program/libicule.so.26 (0x411ab000)
        libjvmaccessgcc3.so.3 => /usr/lib/openoffice.org1.9.104/program/libjvmaccessgcc3.so.3 (0x411d3000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x411d7000)
        libz.so.1 => /usr/lib/libz.so.1 (0x4123f000)
        libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x41252000)
        libuno_salhelpergcc3.so.3 => /usr/lib/openoffice.org1.9.104/program/libuno_salhelpergcc3.so.3 (0x41271000)
        libbasegfx680li.so => /usr/lib/openoffice.org1.9.104/program/libbasegfx680li.so (0x41276000)
        libart_lgpl_2.so.2 => /usr/lib/libart_lgpl_2.so.2 (0x412b6000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0x412cc000)
        /lib/ld-linux.so.2 (0x40000000)
        libicudata.so.26 => /usr/lib/openoffice.org1.9.104/program/libicudata.so.26 (0x413e0000)

This problem may not be specific to Fedora. Please see:

http://lists.debian.org/debian-glibc/2005/05/msg00030.html

Comment 1 James Hunt 2005-06-18 08:26:00 UTC
I have the same problem, although the error message is very slightly different:

> ooffice
/usr/lib/openoffice.org1.9.104/program/javaldx:
/lib/obsolete/linuxthreads/i686/libpthread.so.0: version `GLIBC_2.3.3' not found
(required by /usr/lib/openoffice.org1.9.104/program/libuno_sal.so.3)
/usr/lib/openoffice.org1.9.104/program/soffice.bin:
/lib/obsolete/linuxthreads/i686/libpthread.so.0: version `GLIBC_2.3.3' not found
(required by /usr/lib/openoffice.org1.9.104/program/libuno_sal.so.3)


Comment 2 Stephen Sekula 2005-06-22 04:06:45 UTC
I've done a little more investigating. The problem appears to boil down to a
very simple one: soffice.bin and javadx are picking up the wrong libpthread.so.0
library.

If we look at the versions supported by
/lib/obsolete/linuxthreads/i686/libpthread.so.0:

> strings /lib/obsolete/linuxthreads/i686/libpthread.so.0 | grep "^GLIBC_2.3"
GLIBC_2.3.2
GLIBC_2.3

We quickly see that the complaint made by the binaries is legit. If we look for
other instances of libpthread.so.0:

> locate libpthread.so.0
/lib/libpthread.so.0

Checking what it supports:

> strings /lib/libpthread.so.0 | grep "^GLIBC_2.3"
GLIBC_2.3.2
GLIBC_2.3.3
GLIBC_2.3.4

This looks to be the library we want. So why are the binaries picking up the
wrong one?

A check of /etc/ld.so.conf/ provides no clues, nor does LD_LIBRARY_PATH; neither
lists /lib/obsolete/linuxthreads/.

This is likely a trivial problem, but the solution still eludes me. I'll keep
digging.

Comment 3 Stephen Sekula 2005-06-22 04:25:39 UTC
Problem solved. This was a really stupid mistake on my part, and I here place
the solution in case others have done this.

A *very* long time ago, I had to set the following environment variable in order
to get rpm to work properly (I believe - the old memory is fuzzy on this one...):

LD_ASSUME_KERNEL=2.2.5

Unsetting this fixes the problem.

Comment 4 Caolan McNamara 2005-06-22 08:04:05 UTC
ah!, good stuff. I was baffled as to where this could be coming from.

Comment 5 James Hunt 2005-06-28 11:45:17 UTC
Confirmed - works for me too ;-)

Comment 6 Bas Meijer 2006-01-26 09:49:53 UTC
not for us

Comment 7 Caolan McNamara 2006-01-26 10:02:04 UTC
Bas: what ?, you are getting

/lib/obsolete/linuxthreads/libpthread.so.0: version `GLIBC_2.3.3' not found
(required by /usr/lib/openoffice.orgX/program/libuno_sal.so.3)

when you run openoffice from a terminal and the above fixes don't work for you ?

C.


Note You need to log in before you can comment on or make changes to this bug.