Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160756 - jpilot dies w/ glibc backtrace: free(): invalid pointer
Summary: jpilot dies w/ glibc backtrace: free(): invalid pointer
Keywords:
Status: CLOSED DUPLICATE of bug 160757
Alias: None
Product: Fedora
Classification: Fedora
Component: jpilot
Version: 4
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 05:11 UTC by Bob Arendt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-17 06:21:51 UTC


Attachments (Terms of Use)

Description Bob Arendt 2005-06-17 05:11:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Today's update of jpilot dies repeatable on startup, generating a glibc
backtrace.  To ensure this wasn't the effect of prior data, I removed my
$HOME/.jpilot directory.  jpilot started properly.  Entering the device,
it will start syncing, and die with a backtrace partway through.  Attempts
to start thereafter yeild an immediate backtrace.

Regressing to jpilot-0.99.7-2 works.


Version-Release number of selected component (if applicable):
jpilot-0.99.8-0.pre9.fc4.1

How reproducible:
Always

Steps to Reproduce:
1.  Remove $HOME/.jpilot
2.  Start jpilot, set the device to /dev/pilot
3.  Push m125 cradle sync button, then the sync button on jpilot
4.  Sync starts, the it dies and displays a backtrace.

Actual Results:  See attached for initial backtrace, and subsequent startup backtrace.

Additional info:

20% lsusb
Bus 005 Device 001: ID 0000:0000  
Bus 004 Device 001: ID 0000:0000  
Bus 003 Device 004: ID 0830:0040 Palm, Inc. Palm M125
Bus 003 Device 001: ID 0000:0000  
Bus 002 Device 001: ID 0000:0000  
Bus 001 Device 001: ID 0000:0000  
21% ls -l /dev/pilot 
crw-------  1 rda uucp 188, 1 Jun 16 21:47 /dev/pilot
22% jpilot
slow_sync_application: Unable to open file: Keys-Gtkr
*** glibc detected *** jpilot: free(): invalid pointer: 0x43ba4acf ***
======= Backtrace: =========
/lib/libc.so.6[0x438bf424]
/lib/libc.so.6(__libc_free+0x77)[0x438bf95f]
jpilot(get_todos2+0x207)[0x809a423]
jpilot(todo_update_clist+0x72)[0x809c940]
jpilot(datebook_gui+0x124f)[0x807193c]
jpilot[0x807d155]
/usr/lib/libgdk-x11-2.0.so.0[0x48ffb800]
/usr/lib/libglib-2.0.so.0[0x43bc43ac]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x1dc)[0x43b9e3ee]
/usr/lib/libglib-2.0.so.0[0x43ba13f6]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1a1)[0x43ba16e3]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb4)[0x491821b5]
jpilot(main+0x2107)[0x807f2f0]
/lib/libc.so.6(__libc_start_main+0xc6)[0x43870de6]
jpilot[0x80539c1]
======= Memory map: ========
00111000-0011b000 r-xp 00000000 03:02 180277     /usr/lib/jpilot/plugins/libexpense.so.0.0.0
0011b000-0011c000 rwxp 00009000 03:02 180277     /usr/lib/jpilot/plugins/libexpense.so.0.0.0
  ... snip ...

Comment 1 Ivana Varekova 2005-06-17 06:21:51 UTC

*** This bug has been marked as a duplicate of 160757 ***


Note You need to log in before you can comment on or make changes to this bug.