Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160748 - After upgrade to FC4, cyrus-imapd fails with "DBERROR: DB4"
Summary: After upgrade to FC4, cyrus-imapd fails with "DBERROR: DB4"
Keywords:
Status: CLOSED DUPLICATE of bug 160317
Alias: None
Product: Fedora
Classification: Fedora
Component: cyrus-imapd
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: John Dennis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 02:28 UTC by saul
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-17 14:53:14 UTC


Attachments (Terms of Use)

Description saul 2005-06-17 02:28:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
After upgrading to FC4 and the Cyrus IMAP
package from extras, any attempt to do
anything fails with the following syslog
messages:

Jun 16 22:20:53 gateway imaps[11267]: DBERROR A
                                              : db4
Jun 16 22:20:53 gateway imaps[11267]: DBERROR: critical database situation

This, unfortunately, includes reconstruct, so there's
no obvious way out of the problem.


Version-Release number of selected component (if applicable):
cyrus-imapd-2.2.12-6.fc4.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1.Upgrade Cyrus-IMAPD from FC3 to FC4
2.
3.
  

Actual Results:  Cyrus wouldn't start, and wouldn't run.

Expected Results:  A functioning IMAP server.

Additional info:

I've tried everything I can think of, including
rebuilding the package, rebuilding the FC3 package
on FC4, and the like, all with the same results.

Comment 1 Tom Conder 2005-06-17 03:16:32 UTC
I concur. I, too, see this error. My errors look like this:

Jun 16 01:46:02 phyber pop3[17601]: DBERROR <84>ÃÂ^H^H: db4
Jun 16 01:46:02 phyber pop3[17601]: DBERROR: critical database situation
Jun 16 01:46:02 phyber imap[17599]: DBERROR ^DA^K^H: db4
Jun 16 01:46:02 phyber pop3s[17602]: DBERROR <84>ÃÂ^H^H: db4
Jun 16 01:46:02 phyber master[17600]: about to exec /usr/lib/cyrus-imapd/imapd
Jun 16 01:46:02 phyber imaps[17600]: DBERROR ^DA^K^H: db4
Jun 16 01:46:02 phyber imaps[17600]: DBERROR: critical database situation
Jun 16 01:46:02 phyber pop3s[17602]: DBERROR: critical database situation
Jun 16 01:46:02 phyber imap[17599]: DBERROR: critical database situation
Jun 16 01:46:02 phyber master[24481]: process 17596 exited, status 75
Jun 16 01:46:02 phyber master[24481]: service pop3 pid 17596 in READY state:
terminated abnormally
Jun 16 01:46:02 phyber master[24481]: process 17594 exited, status 75

Comment 2 John Dennis 2005-06-17 14:53:14 UTC
This is a duplicate of bug #160317, please see that bug report as there are
several work around solutions posted there. The last suggestion by Simon Matter
may represent the easiest. If you follow his suggestion I would appreciate your
updating bug #160317 with your results, we would like to ascertain if that is a
viable field solution.

*** This bug has been marked as a duplicate of 160317 ***


Note You need to log in before you can comment on or make changes to this bug.