Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160740 - Kicker segfaults in qt code, trying to close panel, when exiting kde.
Summary: Kicker segfaults in qt code, trying to close panel, when exiting kde.
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: qt
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL: n/a
Whiteboard:
: 161197 161198 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-17 00:00 UTC by Mickey Stein
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-18 06:03:27 UTC


Attachments (Terms of Use)

Description Mickey Stein 2005-06-17 00:00:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Since kde 3.4* hit rawhide, I've had some unusual behavour when exiting kde to the  shell. (I stay in init 3 normally and start kde via 'startx'). 

Until the last update to qt (noted version above), I would intermittently see the panel appear for about 3-4 seconds before the usual exit to the shell. If this happened I'd see a message like this:

--

DCOPClient::attachInternal. Attach failed Could not open netw
ork socket
DCOPClient::attachInternal. Attach failed Could not open network socket
kicker: Fatal IO error: client killed
ICE default IO error handler doing an exit(), pid = 26026, errno = 32

--

But most of the time it worked without the error and normally exited. 

I tried to move ~/.kde(settings) away but the problem persisted with a clean slate. 

After the recent (yesterday or the day before (13-16 Jun) qt update on rawhide, I now get a repeatable segfault kicker crash 'dialog' box which asks me if I want to save it before exiting. 

This is what I've gotten from it thus far:

"no debugging symbols found)
[KCrash handler]
#3  0x081b12a7 in ?? ()
#4  0xb70f813e in QPtrList<QPopupMenu>::deleteItem ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#5  0xb728b51d in QGList::clear () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#6  0xb65401c9 in PanelServiceMenu::~PanelServiceMenu$base ()
   from /usr/lib/libkdeinit_kicker.so
#7  0xb653bca7 in PanelKMenu::~PanelKMenu$delete ()
   from /usr/lib/libkdeinit_kicker.so
#8  0xb6513f3d in MenuManager::~MenuManager$delete ()
   from /usr/lib/libkdeinit_kicker.so
#9  0xb6fa092c in QObject::~QObject$base ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#10 0xb6f409f5 in QApplication::~QApplication$base ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#11 0xb76b9dfe in KApplication::~KApplication$base ()
   from /usr/lib/libkdecore.so.4
#12 0xb775c5fd in KUniqueApplication::~KUniqueApplication$base ()
   from /usr/lib/libkdecore.so.4
#13 0xb64f6928 in Kicker::~Kicker () from /usr/lib/libkdeinit_kicker.so
#14 0xb64f63f1 in kdemain () from /usr/lib/libkdeinit_kicker.so
#15 0xb65986e0 in kdeinitmain () from /usr/lib/kde3/kicker.so
#16 0x0804de4d in ?? ()
#17 0x0804e4c5 in ?? ()
#18 0x0804eaad in ?? ()
#19 0x0804fb29 in ?? ()
#20 0xb69a2dfb in __libc_start_main () from /lib/libc.so.6
#21 0x0804b911 in ?? ()
"

I know that isn't very good information but I haven't been able to dig up the qt-debuginfo-3.3.4-15 file (oops ! Never mind, I just found it in .. 'debug' folder on the fedora site ;) ) 

I'll see if I can produce a better crash log and report back with that. 

Mick

Version-Release number of selected component (if applicable):
kdebase-3.4.1-0 &  qt-3.3.4-15

How reproducible:
Always

Steps to Reproduce:
1. Start kde from init level 3 via 'startx'.
2. Do anything or nothing in kde
3. Exit kde. 
4. Look for segfault info box.
  

Actual Results:  I get a crashdump in a kde box. 

Expected Results:  I expect it to exit to a fullscreen shell as normal. It does this after I close the crash info box. 

Additional info:

I'm using 'todays' kernel (2.6.12-rc6-git8) and all other software is up-to-date from rawhide.

Comment 1 Mickey Stein 2005-06-18 06:03:27 UTC
This was probably a bad choice of where to file the bug. I moved it upstream to
bugs.kde.org and found a couple of identical already filed reports. 104152 is
closest, and this is 'supposed' to be fixed in the next release of kdebase (3.4.2).

I'll close this out here. 

Comment 2 Ngo Than 2005-06-21 10:33:19 UTC
*** Bug 161198 has been marked as a duplicate of this bug. ***

Comment 3 Ngo Than 2005-06-21 10:34:11 UTC
*** Bug 161197 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.