Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160735 - OOo crashes on startup
Summary: OOo crashes on startup
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-16 22:56 UTC by Rik van Riel
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-28 11:55:48 UTC


Attachments (Terms of Use)

Description Rik van Riel 2005-06-16 22:56:10 UTC
Description of problem:


0x322afe: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1dafe
0x32334c: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e34c
0x5012b8: /lib/tls/libpthread.so.0 + 0xb2b8
0x1f1bee: /lib/ld-linux.so.2 + 0x9bee
0x1f5b08: /lib/ld-linux.so.2 + 0xdb08
0x1fafc0: /lib/ld-linux.so.2 + 0x12fc0
0x562557: /usr/lib/openoffice.org2.0/program/libvos3gcc3.so + 0x19557
(vos::OPipe::accept(vos::OStreamPipe&) + 0x2d)
0x806b91f: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x2391f
(desktop::OfficeIPCThread::run() + 0x1f)
0x55dce5: /usr/lib/openoffice.org2.0/program/libvos3gcc3.so + 0x14ce5
(vos::_cpp_OThread_WorkerFunction(void*) + 0xd)
0x55dd13: /usr/lib/openoffice.org2.0/program/libvos3gcc3.so + 0x14d13
(_OThread_WorkerFunction(void*) + 0x17)
0x31c2a1: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x172a1
0x4fbb17: /lib/tls/libpthread.so.0 + 0x5b17
0x2dc387e: /lib/tls/libc.so.6 + 0xc587e (__clone + 0x5e)

Version-Release number of selected component (if applicable):

openoffice.org-core-1.9.109-6.2.0.fc5

How reproducible:

oowrite <some document>

Additional info:

Despite this backtrace on startup, oowriter seems to work well.  Strange.

Comment 1 Rik van Riel 2005-06-16 22:56:54 UTC
Hmm, and when I close the window with the backtrace in it, oowriter also exits...

Comment 2 Rik van Riel 2005-06-16 23:00:59 UTC
The crash only happened after I removed the .openoffice* directory in my home
dir. With the directory present it does not crash.

Comment 3 Caolan McNamara 2005-06-17 09:57:42 UTC
I'm not seeing it with the same version. With an .openoffice.org2.0 dir before
starting or without one :-(

Comment 4 Caolan McNamara 2005-06-28 11:55:48 UTC
can't reproduce with 1.9.112. possibilities include LD_ASSUME_KERNEL or an un
double-locked shared variable floating around somewhere


Note You need to log in before you can comment on or make changes to this bug.