Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160734 - link to /usr/bin/ksh missing
Summary: link to /usr/bin/ksh missing
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ksh
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-16 22:08 UTC by Scott Lurndal
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-27 14:27:29 UTC


Attachments (Terms of Use)

Description Scott Lurndal 2005-06-16 22:08:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
the PDKSH package included with prior releases of redhat, all the way back to 
redhat 5.1 included links for ksh in /bin and /usr/bin.   The new ksh package (presumably based on David Korns KSH93) only includes the /bin link.   A link to /usr/bin/ksh should be added.   Note that existing installations using NIS to distribute user identity information probably already have /usr/bin/ksh as the login shell (for interoperability with solaris, for example).

Version-Release number of selected component (if applicable):
ksh-20050202

How reproducible:
Always

Steps to Reproduce:
1.set login shell to /usr/bin/ksh
2.try to login
3.
  

Actual Results:  Login fails due to lack of login shell

Expected Results:  Should have logged in.

Additional info:

Comment 1 Karsten Hopp 2005-06-27 14:27:29 UTC
fixed Mar 15 2005, but unfortunately the package was too late for FC-4. Fixed in
-development 


Note You need to log in before you can comment on or make changes to this bug.