Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1607175 - Bond stats in gui are incorrect, showing only stats of one slave member
Summary: Bond stats in gui are incorrect, showing only stats of one slave member
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.Core
Version: 4.2.4.5
Hardware: Unspecified
OS: Unspecified
low
medium vote
Target Milestone: ovirt-4.2.7
: ---
Assignee: Ales Musil
QA Contact: msheena
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-22 22:29 UTC by Miki Shapiro
Modified: 2018-11-02 14:32 UTC (History)
7 users (show)

Fixed In Version: ovirt-engine-4.2.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-02 14:32:48 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
Screenshot showing issue with UI (deleted)
2018-07-22 22:29 UTC, Miki Shapiro
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1511409 None None None Never
oVirt gerrit 93806 master MERGED webadmin: Fix host network interface bond statstics 2018-08-27 11:53:54 UTC
oVirt gerrit 93948 ovirt-engine-4.2 MERGED webadmin: Fix host network interface bond statstics 2018-08-31 08:54:36 UTC

Internal Links: 1511409

Description Miki Shapiro 2018-07-22 22:29:10 UTC
Created attachment 1469819 [details]
Screenshot showing issue with UI

Description of problem:
GUI issue - 
BOND interface displays RX/TX stats of only one slave member, instead of the aggregate. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Configure bond with multiple slaves. Put traffic through.
2. In the GUI, go to Hosts -> select host -> Network Interfaces tab. Expand the bond interface to show slaves.


Actual results:
3. Observe:
(copy-paste of text from browser)

bond0
MAC
00:1a:92:75:be:79
Rx Rate (Mbps)
< 1
Total Rx (Bytes)
444,385   <==== These stats (RX, TX etc) are incorrect. It's what slave enp0s7 received, not what went through the bond. See below
Tx Rate (Mbps)
< 1
Total Tx (Bytes)
3,588
3000 Mbps
0 Pkts

1 Logical Network
3 Slaves
MAC	MAC	Speed	Rx Rate (Mbps)	Tx Rate (Mbps)	Total Rx (Mbps)	Total Tx (Mbps)	Drops (Pkts)
enp0s7
00:1a:92:75:be:79
1000
< 1
< 1
444,385  <==== what slave interface enp0s7 received
3,588
0

enp2s0
00:e0:4c:2b:2e:b2
1000
49
< 1
3,038,457,140    <==== what interface enp2s0 received
53,154,076
0


enp3s0
00:e0:4c:5b:28:54
1000
72
< 1
4,474,104,894  <==== what interface enp3s0 received
57,969,718
0



Expected results:
The bond should show the stats of all its slaves


Additional info:

Comment 1 Dan Kenigsberg 2018-07-25 13:54:13 UTC
What is reported from Linux on /sys/class/net/*/stats/* ?

Comment 2 Dan Kenigsberg 2018-08-01 07:46:43 UTC
Might be related to bug 1511409

Comment 3 Dan Kenigsberg 2018-08-08 07:38:45 UTC
Answering myself: `vdsm-client Host getStats` reports the correct bond statistics from Linux.

REST also reports the correct value, so indeed this is a UI problem.

Comment 4 msheena 2018-09-25 12:17:39 UTC
Can you please write down what was the bond's mode? also in what way did you put traffic on the bond/slaves? so I may reproduce.

Using iperf with bond mode:
- 4 (default): 1/3 slaves was reporting the traffic as well as the bond but other 
               slaves were not reporting anything but 1.
- 3: traffic was reported for all slaves, but not on bond.

Comment 5 msheena 2018-10-02 05:28:33 UTC
Alesh, 
Maybe you can help us understand which mode/s should be tested, and in what way is the patch reflected?

Comment 6 Ales Musil 2018-10-02 08:23:36 UTC
I was using mode 4 for that. There is still some management traffic in the disabled interface which should be reflected in the overall bond statistics.

Comment 7 msheena 2018-10-03 09:16:52 UTC
Verified on:

rhvm-4.2.7.1-0.1.el7ev.noarch

Comment 8 Sandro Bonazzola 2018-11-02 14:32:48 UTC
This bugzilla is included in oVirt 4.2.7 release, published on November 2nd 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.